Camera not starting even after charging

January 28, 2018 at 08:30:48
Specs: Android
I'm having trouble turning my camera (Nikon S800c) on. When I hit the power button, nothing happens. When I plug it in to charge it, nothing happens except that the power button flashes. I've tried to take the battery out and put it back in, charging it, and so on but nothing has worked. Do you have any suggestions?

See More: Camera not starting even after charging

Report •

#1
January 28, 2018 at 09:06:06
Seems you're not alone with this problem...

Are you sure the charger unit is OK?

Have read of this olde(r) thread about the same camera and issue.

https://www.computing.net/answers/d...


Report •

#2
January 28, 2018 at 09:47:26
Running the latest firmware?

Report •

#3
January 29, 2018 at 09:01:17
Time for a new camera. The Nikon point and shoot cameras are notorious for this issue. Do a search for Nikon on this site and you will see there are many other users who have the same problem.

Report •

Related Solutions

#4
January 29, 2018 at 13:53:55
This looks like a hardware fault, not just some setting.
Unless you are expert, taking the camera apart to fix it would be out of the question.

Always pop back and let us know the outcome - thanks


Report •

Ask Question