Arcsoft Connect Not Working

Hewlett-packard / Hp 530 notebook pc
February 1, 2009 at 08:11:29
Specs: Windows Vista, 512 MB
I have bought a Labtec 1200 webcam, there is nothing wrong with the cam, but I need to register the product. Apparently the only way I can do this, is by clicking the icon Start Service, powered by Arcsoft Connect. This icon is not working on my pc - there is no response when I double click it. It seems there could be a compatibility problem? I'm not sure. Without Arcsoft Connect / Start Service, I cannot register, and therefore cannot use the cam.
Can someone help me please?

See More: Arcsoft Connect Not Working

Report •

February 3, 2009 at 18:16:33
Labtec and Arcsoft are different apps.,do they rely in each other?
If so what is the relation?
Do Arcsoft came with your webcam?
Do you have WebCam Companion 3?
Do you try on Labtec or Arcsoft sites?

I think if your problem is registration of the WCam go here and do it here: and create an acc.

Report •

February 4, 2009 at 02:37:37
Thanks for your reply.
I have tried the sites. I am unable to register the conventional way, because I cannot access the home screen (which is where the registration code is), as my trial period of 14 days has expired.
I have Webcam Companion 2.
Arcsoft is the software, Labtec is the cam. The products included on the CD are:
Arcsoft Webcam Companion 2,
Arcsoft Magic-i-3,
Arcsoft Photo Impression 5, and
Arcsoft Video Impression 2.
There is nothing wrong with the cam, it worked fine during the trial period. I cannot use any of the above becuause I am not registered, and there is no registration code I can access.
Arcsoft has been unhelpful and had given me general answers that would be given to people who have not registered which I cannot do).

Report •

Related Solutions

Ask Question