Laptop not working when plugged in

July 23, 2015 at 20:03:31
Specs: Windows XP
My computer which is a LATITUDE | D620 Dell laptop works great until i plug it in. Then it goes super slow , freezes and doesn't work. As soon as i unplug it, it starts working immediately.

Any ideas?

Could the fan not working right cause this?

It does get hot pretty fast.

Also another question is , it shuts off if you bump the chord only when its plugged in. Bad connector?


See More: Laptop not working when plugged in

Report •


#1
July 23, 2015 at 21:51:53
It's probably the charger. Posting # 11 here:

http://www.computing.net/answers/ne...

said the problem went away when they used a different charger. This one says if the charger type isn't recognized the laptop powers down while charging:

http://forum.notebookreview.com/thr...

Assuming you get another charger, get an offical Dell/Dell OEM and not one of the crappy knock-offs. I've had better luck with used official Dell or Toshiba chargers on ebay than the cheap new off-brand ones. Also consider getting a 90 watt charger. You're probably using a 65 watt one now.


Report •

#2
July 25, 2015 at 05:21:29
When something changes if you move it, a fault (connection or short) lies in or around that area.

Always pop back and let us know the outcome - thanks

message edited by Derek


Report •

#3
July 25, 2015 at 20:39:45
My previous charger broke, and it did the turning off thing before. It does it with any charger.

As for the freezing when plugged in, the same charger works fine on another laptop.


Report •

Related Solutions

#4
July 25, 2015 at 22:39:13
How many Dell or Dell OEM chargers have you tried? The slowing down thing seems to affect Dell models more so than laptops from other manufacturers.

Report •

#5
July 26, 2015 at 05:06:53
"Dell laptop works great until i plug it in"

Does it give trouble when plugged into the computer even if it is not plugged into the domestic power?

Always pop back and let us know the outcome - thanks


Report •

Ask Question