Click here for important information about

Solved Blu - Ray Smart Play not connecting to Netflix

July 14, 2012 at 08:30:02
Specs: Windows 7
I have read the numerous posts on this exact same problem, so I won't repeat everyone else. But after calling in two separate times, going through the many hard-resets, unplugs, etc., they were to have someone call me back - "escalate" the problem. No one called. The second time I called in after waiting for two weeks, I refused to be escalated again and they moved me from Tier 1 to Tier 2 and again, went through everything again and again refused to let them have someone call me back - and they sent me to a ECR Department. "Execustive Customer Response" perhaps?? A very soft spoken man told me that they will arrange for me to have the player sent in for repair. That is when I got mad. When I tried to remain calm and explain to him that the numerous other people at Samsung could have told me that and even more important I know I can take it in to have it repaired by simply walking in to my Best Buy where I bought it....he simply said "OK" in such a soft, un-interested voice I had to ask him to repeat himself so I could hear him clearly. The more upset I got, the more un-interested he became.
This response from Samsung is so inappropriate, unprofessional and disappointing I am truly speechless. Especially when it comes at a time that most companies are attempting to get us to buy from them, and Samsung obviously does not care once they have your money.

Anyone have any ideas what to do next????

See More: Blu - Ray Smart Play not connecting to Netflix

July 15, 2012 at 09:47:02
Do you have a netflix account?

if so than take it to have it fixed, there isn't enough detail in your post to make a diagnostic

Report •

July 16, 2012 at 23:36:36
✔ Best Answer
I hope this helps you....

This what I stumbled across this solution on this site when I was looking for a solution to the error message via Netflix app on my Blu-ray player (HT-E5400) stating it was unable to connect online.

My DNS was set for auto so I changed it to manual and input the following:

DNS: And all of the sudden it finally worked after days of errors'

The following info is what I found on this site:

. . . I was going to blame samsung but i don't think it is their problem, per se....

my bet is that the real issue is in DNS lookup being blocked by my ISP.

What I did is used static IP settings for the samsung product in question and pointed its DNS

My router is
DHCP range is through
subnet mask is

so I set my bluray up as follows:

ip address:
subnet mask:

Report •
Related Solutions

Ask Question