using administrator to reset psswrd

January 19, 2009 at 23:10:20
Specs: Windows Vista, 4 GB
I installed MySQL on Vista. The root password I created I lost (even though I wrote it down) but think it was ‘My1SQL’ . When I tried to logon - access was denied. However, I found out later - not from MySQL - that passwords with numbers in it dont work so well (hear say on the web).

I got the procedure from the MySQL manual on how to reset the root password, and I turned on the ‘special’ administrator’s account in vista so I would have the correct rights and privileges to access everything I needed to access and tried it.

The procedure included stopping My SQL thru the control panel>administrative tools>services, and starting it again thru the command line using a start up file that changes the password.

When I tried it I got the error msg - 'C:\Program' is not recognized as an internal or external command, operable program or batch file.
This is the command I used from the c:\> prompt –
C:\Program Files (x86)\mysql\mysql server 5.1\bin\mysqld --init-file=C:\mysql-init.txt

Am I missing some rights or privileges? why wont it let me run this?

See More: using administrator to reset psswrd

Report •

January 20, 2009 at 10:59:41
Windows sees the first space in your command after "C:\Program " as the end of the command, and everything after it as arguments to the command. Try enclosing the command in quotes, like this:

"C:\Program Files (x86)\mysql\mysql server 5.1\bin\mysqld" --init-file=C:\mysql-init.txt

that way everything in quotes is the command - the path to the mysql executable - and everything following is arguments to the command. Make sense?

Report •

January 20, 2009 at 21:17:24
Message: Thank you lowhanginghoney, I tried it and it got a little further.

Using the " to compensate for the spaces, vista came back with another error msg:

The filename, directory name, or volume label syntax is incorrect.

I right clicked on the volume in 'my computer' - (C:) and gave full control to the administrator user (me) and the Vista Administrator. Then I tried it again and - you guessed it - I got a different error msg -

090120 22:45:44 InnoDB: Operating system error number 5 in a file operation.
InnoDB: The Error means mysql does not have the access rights to the directory. It may also be you have created a subdirectory File name .\ibdata1
InnoDB: File operation call:'open'. Cannot continue operation.

So aside from my syntax error with the " when using spaces (thank you for the tip lowhanginghoney), It now feels like I am at a point where Vista will not let mysql overwrite the root user password - I need to get Vista to grant the proper rights to mysql so it can reset the password.

Thank you for your help earlier, Please advise.

Report •

Related Solutions

Ask Question