New cpu installed and pc wont turn on.

April 14, 2020 at 15:10:40
Specs: Win 10, I7-9700k
I replaced my i5 6600k processor with a new i7 9700k. Took it out and installed the same as when i built the PC. However, it will not boot. Even the fans dont spin, pressing the power button does absolutely nothing. I have updated the BIOS to the latest version, i am using a Z170 Asus motherboard.
Even stranger is when i installed the old one back in, the computer booted without a single issue. I ensured the cooler tower was totally clean before applying new paste to the processor.

See More: New cpu installed and pc wont turn on.

Reply ↓  Report •

#1
April 14, 2020 at 21:04:26
Sorry the 9th generation Intel Core K series processors require the Z390 chipset to work best but will never work on a Z170 chipset. Absolutely a 300 series chipset and possibly with the latest BIOS update may be required.
https://www.intel.com/content/www/u...

You have to be a little bit crazy to keep you from going insane.

message edited by Fingers


Reply ↓  Report •

#2
April 15, 2020 at 01:40:40
I didnt bloody think about the chipset!! Damn, but thanks very much for your help. Looks like a new motherboard will. Be on the way shortly

Reply ↓  Report •

#3
April 15, 2020 at 02:11:45
"but will never work"
Nice work Fingers.

Reply ↓  Report •

Related Solutions

#4
April 15, 2020 at 02:53:38
it's possible with bios modding, on a really high end z170 board. absolutely do not recommend tho.

here is some insight:

https://www.pcbuildersclub.com/en/2...

luumi from hwbot.org made quite a in depth guide ;)

specs: https://www.userbenchmark.com/UserR...


Reply ↓  Report •

Ask Question