Solved Unable to flash sony xperia z2 d6503

Sony Brand sony xperia z2 d6503 black (f...
November 9, 2015 at 02:34:01
Specs: Android Version 5.1.1, 2.3GHZ
Good day,

I have this Sony Xperia Z2 D6503 mobile phone which I am having trouble flashing, I have unlocked the boot-loader. I have flashed a custom Rom on this phone before, using suggestions that I have read on the Xda-Developers site. I reverted back to stock Rom after a while, because the custom Rom I flashed had issues with network service signal, and it began to restart the phone on it's own. I have found a good Rom and I am trying to flash this but it doesn't work. I followed all the steps like what I did in the first successful flash. I downgraded the stock Rom, rooted the stock Rom, installed CWM recovery, the exact same way as the first. Also I ensured that the MD5 number is a match and the Rom still won't flash, even tried TWRP recovery. Is it possible that my boot-loader got re-locked when I reverted back to stock Rom using flash-tool.

Thanks again
Roger


See More: Unable to flash sony xperia z2 d6503

Report •

#1
November 15, 2015 at 16:23:43
✔ Best Answer
It should be possible to flash the custom rom without rooting the device.
First you have to flash stock rom, then flash custom rom, then root the device and install custom recovery if you like.

Report •

#2
November 16, 2015 at 08:49:10
;Thanks for the response. Actually I was able to flash the ROM. I flashed ftf file with Sony flash-tool, Had to downgrade the os first, the rooted and installed a recovery. Didn't wipe data or any of the other processes that it usually required. And worked perfectly. Thanks for the advice.

message edited by Freakyfonty


Report •

#3
November 16, 2015 at 13:18:19
Always a pleasure.
Would be nice if you can select "Best answer", so others can see, that the problem was solved.

Report •
Related Solutions


Ask Question