Phone connecting to low signal instead of good signal wifi

August 17, 2019 at 10:05:23
Specs: Android 9
Downstairs I have the ISP provided router, all with its default settings (SSID, password etc). The ISP router is connected to a Devolo Powerline Wifi. I have a second Devolo Powerline Wifi in my room (same SSID and password as the ISP router).

My laptop is automatically connecting to the best Wifi signal based on where I am in the house (as expected), however my Phone (Oneplus 7) always connects to the ISP router.

If I forget the network, it shows up with full signal. Once I reconnect after a few seconds the signal dies again (presumably switching back to the ISP router)


See More: Phone connecting to low signal instead of good signal wifi

Reply ↓  Report •

#1
August 17, 2019 at 21:13:24
Try unplugging the problem router feom the power supply for about 10 seconds, then plug it back in.

Reply ↓  Report •

#2
August 18, 2019 at 00:54:54
Thanks for the swift response. Unfortunately this didn't do anything.

Reply ↓  Report •

#3
August 18, 2019 at 06:33:38
Are both routers broadcasting on the same frequency, IE. 2.4GHz or 5GHz?
If not, see if you can do so. 2.4GHz will be a slower connection but will travel farther. 5GHz will have a faster throughput but has a weaker signal.

Also, I'm not so sure having two connections with the same SSID is such a good idea, you might try changing one of them to a different name and see if that helps.

One last thing to try, there are several channels available for WiFi, if two devices are using the same channel, it can cause problems with interference. Try changing the channel on the problem device.

message edited by THX 1138


Reply ↓  Report •

Related Solutions

#4
August 18, 2019 at 10:03:23
Changing the SSID's to be different does work but I was hoping to have a seamless extended network (which funnily enough I had working in my previous residence with the same Powerline devices) so that I don't have to worry about choosing which one I'm connected to based on where I am around the house. It doesn't always pick the connection with the best signal.

My ISP provided router appears to output both 2.4GHz and 5GHz under the same SSID.
The Powerline only outputs 2.4GHz.

message edited by jonarooni


Reply ↓  Report •

Ask Question