Acer Iconia B1 wont boot

Acer Iconia b1
September 7, 2013 at 19:20:47
Specs: Android, 6gb
My sons Acer Iconia B1 will not boot up.
So far I have tried resetting it numerous times.
I tried holding down the VOLUME UP button then the POWER button for 3 seconds releasing it while still holding down the volume button - no joy.
I also tried using a toothpick to hold in the reset button for 10 seconds (just above the power button) - no joy either.
It was lteft plugged in for a number of hours to help charge it but makes no difference.
Just a dead black screen mostly.
Sometimes when trying the above the screen gives off a number of faint flashes but that's it.
Any help would be greatly appreciated.
Kind regards and thanks in advance,

See More: Acer Iconia B1 wont boot

Report •

September 13, 2013 at 10:36:34
I Googled that. One poster on a site recommended pressing in the reset button for 10 seconds exactly, then waiting 5 seconds before pressing the power button.

message edited by Jennifer SUMN

Report •

September 13, 2013 at 12:32:28
Thanks for the reply - I actually tried that too and various other methods all to no avail. So I've brought it back to Argos and it has been sent off to be checked out. I have a funny feeling that they will say it was my sons fault or that the fault will not be under warranty and I will probably have to pay ... don't know yet.
I will post the outcome.
Thanks again,

Report •
Related Solutions

Ask Question