Articles

xp setup doesn't recognize drives

June 15, 2006 at 10:16:29
Specs: Windows XP Professional, Pentium 4 ~ 3.8GHz / 2GB

Windows Xp Media Center setup (running at boot) doesn't recognize my serial ATA hard drives, and I can't seem to get the SATA/RAID Controller drivers (F6 method) to help it see them. I have no operating system right now, because I formatted the drive to get rid of a horrible virus. The BIOS sees the drives, but not the xp setup. Any help would be appreciated.

See More: xp setup doesnt recognize drives

Report •


#1
June 15, 2006 at 10:22:38

What kind of Windows Xp Media Center setup are you running? Is it Sony VAIO supplied CD (Restore CD)?

i_XpUser


Report •

#2
June 15, 2006 at 11:30:02

1) Look at BIOS; you might have to change the SATA mode from "native" to "legacy" or something like that. I know we had to do that at work in order to Ghost SATA drives.

2) If you have a floppy with a bunch of SATA drivers and aren't sure which one to select, don't press F6. Instead, just insert the floppy after the CD boots up, and everything should be detected automatically.

Good Luck


Report •

#3
June 15, 2006 at 11:48:09

No, it's not a restore CD, but it is a Sony VAIO. A friend of mine lent me his copy of XP Media Center 2005, and I was just going to use my CD-key that came with the computer (since the disks did not come with it). Anyway, I've tried every SATA driver I can find, and still nothing. It doesn't see the drives, even though the BIOS does with no problem. I looked on the motherboard for its identity information, and it says it's an "Intel Desktop Board D945PPR D945GPR". It might be helpful to point out that if I press Enter to continue even when the setup says "Unknown Disk (There is no disk in this drive)" or when I press F3 to exit when I get to this screen, I'll get the following blue screen: "A problem has been detected and windows has been shut down to prevent damage to your computer. The problem seems to be caused by the following file: setupdd.sys" Then below that line it says: "PAGE_FAULT_IN_NONPAGED_AREA" Then at the bottom of the page it says: "*** STOP: 0x00000050 (0xE57A73F8, 0x00000000, 0x00000002)" Then below that it says: "setupdd.sys - Address F74139A8 base at F73EC000, DateStamp 41107c8f"

Report •

Related Solutions

#4
June 15, 2006 at 11:48:39

Just to clarify my previous post: The reason I asked about the CD is that M$ does not manufacture & sell stand-alone WMCE CD. Major OEM System Builders are the only ones that pre-install this OS.

i_XpUser


Report •

#5
June 15, 2006 at 11:53:05

Just to clarify my post, it did the same thing when I tried to install XP Pro...

Report •

#6
June 15, 2006 at 12:07:29

Also, the motherboard is a E210882.

Report •

#7
June 15, 2006 at 12:33:39

You need to put the SATA Drivers on a Floppy Disk, then hit F6 and you need to point it to the drivers on floppy.

Your Sony Key Code will only work with the pre-installed Windows XP.

Also whilst you can purchase Media Centre Edition it is designed to work with certain hardware...

USE PC-DOS IT IS QUICKER!


Report •

#8
June 15, 2006 at 12:37:52

Also whilst you can purchase Media Centre Edition

Sorry to disagree. Once again M$ does not sell WMCE as a standalone product. (The Net is full of counterfeit WMCEs).

i_XpUser


Report •

#9
June 15, 2006 at 13:02:25

Okay, since things are off topic, I thought I'd remention that I still have the problem with SATA drivers and setupdd.sys

I'll use my XP Pro CD if necessary. I just want my computer to work again. Is anyone out there knowledgable enough to solve this problem?


Report •

#10
June 15, 2006 at 13:03:49

and in response to the F6 suggestion, that's what I've been trying already with all the Intel SATA drivers I can get my paws on. Nothing works, and I am wondering if there's something else going on to prevent setup from seeing the hard drives.

Report •

#11
August 2, 2006 at 22:45:32

Matthew, was your problem ever resolved? I am having the exact same issue wth my system: after a RAID0 hard drive failure, I'm attempting to re-install Windows XP Pro, and while my BIOS acknowledges my drives and the on-board RAID set-up seems to work fine, the damned Microsoft install can't see the drives, even after I load the SATA RAID drivers from floppy with F6.

Report •


Ask Question