Windows will not detect IDE drives

August 4, 2005 at 21:22:09
Specs: Windows XP, 850

I receatly attempted to update the firmware for a Mad CD/DVD rom, Model BKM-56X16V2 Combo Drive. During the update, I recieved a error message, ERR: Fail to open input File!" I tried to reboot, and now the computer will not detect drives. It freezes at the boot screen "detecting IDE drives". I have two DVD drives and neither will come on nor will the hard drives. What can I do to correct this issue? Before to flash, the computer was working fine.

See More: Windows will not detect IDE drives

Report •


#1
August 4, 2005 at 22:58:15

A great number of people attempt to flash their computers BIOS every year and end up with a very large paper-weight.

You could try removing the battery for a few minutes, or using the CMOS Clear jumper, to reset the BIOS to default.

You can take the unit to a local repair shop (ask them before you go if they can fix your problem) or you can buy and install a new BIOS chip for that motherboard yourself.

Most replacement BIOS Chips will cost you around $25-US but you will probably be stuck with updating the data version on it once you get it installed. This may lead to the cycle called "flash and purchase."

With a “bad flash” there really isn’t to much you can do except replace the chip.


Report •

#2
August 4, 2005 at 23:28:31

OK, I got the computer to boot up. All I have to do was unplug both of my CD/DVD roms. By the way, this is what I was attepmting to flash (only one and now both do not work). My issue now has slightly changed. When the DVD drives or drive is connected, the system will not boot. It still says, "detecting IDE drives." If I disconnect the drives, the computer boots however no DVD/CD drives. Please Advise?

Report •

#3
August 5, 2005 at 07:25:22

Have you set the jumpers at the back of the roms to the appropiate setting(s) i.e. as 'slaves' on IDE1 and IDE2?

And do you have the IDE cable(s) plugged into the 40pin connector on the Rom the right way round (although there is usually a guide notch that prevents wrong orientation). The red stripe on the IDE cable always goes to the side nearest the power connector.

One other point is how old are your harddrives? Older models (under 8.4G) may not run properly on newer motherboards. If they are recognised, as soon as a newer ROM drive goes across them on the same IDE, HD detection stops.

Perhaps you could try the HD's on IDE1 and the CD ROMS both on IDE2, setting the roms as slaves in both cases.

Have you let the (Award?) BIOS run thru all checks to properly detect the harddrives and saved the results? (F10/Yes).

These are all basics of course but worth checking.


Report •

Related Solutions

#4
August 5, 2005 at 07:29:30

OOPS!!! Let me correct Paragraph 4 above! It should have read "Perhaps you could try the HD's as master and slave on IDE1 and the CD ROMS as master and slave on IDE2".



Report •

#5
August 5, 2005 at 10:39:23

Flashing ROM on a CDR-RW or other like items is just as tricky as flashing the motherboard.

From here it sounds like you tried flashing one drive; but both were hooked on the same data ribbon, is that correct? You may have gotten some cross pollination or a partial flash of both drives.

Try booting the unit to an A:\ prompt using a Windows 9x emergency boot disk if possible, and then connect the drive that you tried to flash. Now try again. Sometimes it is required to flash from Windows so booting from the Win9x disk may not be possible. See what your flash instructions say. Be friggin careful hooking up the data ribbon as the unit will be hot and frying the motherboard is possible.

If you are successful, you will probably need to get the correct firmware for the other drive.


Report •

#6
August 5, 2005 at 21:31:53

I tried removing the DVD drive and installing after I recieved the "A". So far so good. However, after I run the flash program, I recieve the same error message, "ERR: Fail to open input File!" There is no power on the DVD drive. Also when I do boot up (without the DVD drives) I recieve a message that states RAID contoller is missing. I also have a yellow question mark in the device manager for Raid controller. Any additional advice is greatly appreciated?

Report •

#7
August 6, 2005 at 02:53:13

Delete the Raid controller with the yellow asterisk. Windows will find it during the next boot sequence and repair it. If not then you didn't need it.

The DVD needs the power cable and the data ribbon on it to load the flash prom. So boot the unit - hook up the DVD completely and try the flash. Then try the second drive.

We may have to face the music on this one! The firmware chip may be gone!!! I just hope you didn’t get the motherboards BIOS somehow too.

Tell me who manufactures that drive. Give me the URL for that firmware file. Get me looking in the right direction and maybe I won’t give up on this. I hate to get beat like this.


Report •

#8
August 6, 2005 at 06:57:30

I have two DVD drives. The one I was attempting to flash is Mad Dog/Artec Model BKM-52X16C Firmware V2EF/W1.83*. The other DVD drive is a Buslink, Model DVRW812D.

I also tried deleating the raid controller. However, it returned with the same issue.


Report •

#9
August 7, 2005 at 12:24:33

Sorry,
I forgot to include the page for flash:

http://www.artecusa.com/tech-support-firmware.html

I really appreciate you trying to help me out.


Report •


Ask Question