Solved Which versions of i explorer can I load on XP

November 24, 2012 at 15:03:14
Specs: Windows XP

I have very slow response and get a message that V7 is not supported by some programs like Iheartradio.

See More: Which versions of i explorer can I load on XP

Report •


#1
November 24, 2012 at 15:16:18

I believe IE8 is the latest one supported in XP. If you continue to have problems with IE you can always try an alternative browser such as firefox.

Goin' Fishin' (Some day)


Report •

#2
November 24, 2012 at 15:41:52
✔ Best Answer

Spot on Richard59.
You can even use Chrome if you trust them (I don't).

Ouklip
You can get IE8 here:
http://www.microsoft.com/en-us/down...

That does better than IE7 but even so, some websites now complain that it's outdated.
Eventually anyone who wants to stick with XP will need to migrate to an alternative browser.

You might care to read this, also Part 1 - see link at the bottom:
http://www.computing.net/howtos/sho...

Always pop back and let us know the outcome - thanks


Report •

#3
November 24, 2012 at 17:52:19

"You can even use Chrome if you trust them (I don't)"

Agreed, stay away from Chrome. Update to IE8 & install Fiefox as an alternate browser. Have you installed SP3?


Report •

Related Solutions

#4
November 25, 2012 at 03:22:35

I loaded Firefox and could not run Iheartradio. I have tried Chrome and it was slower. Thanks for the suggestions

Report •

#5
November 25, 2012 at 03:31:14

How much ram/memory do you have?

What size is the CPU?


Report •

#6
November 25, 2012 at 05:14:50

I loaded IE8 and there is a marked improvement. The only fly in the ointment is the site Iheartradio, it still yells me the browser is outdated, I can live with that.

Thanks very, very much to all the advice. I will continue to try other suggestions.


Report •

#7
November 25, 2012 at 07:48:04

It may not be your browser that is at the root of your problem.
According to Iheartradio all of the following browsers are supported:


You can listen to iHeartRadio using the following web browser and Flash versions:

BROWSER

Internet Explorer 7, 8, 9
Firefox 4 and above
Safari (all versions)
Google Chrome (all versions)

FLASH

Flash Player 10 and above

MIKE

http://www.skeptic.com/


Report •

#8
November 25, 2012 at 08:36:36

I've seen complaints about IE8 on various websites, so it seems it is now getting lack of support but on XP that is as far as you can go. Sometimes putting sites in compatibility view helps (in Tools) but not always.

However as per response #7, maybe it is some other issue but right now I have no idea what.

Always pop back and let us know the outcome - thanks


Report •


Ask Question