Vaio recovery yields I/O error for CD/ DVD

August 18, 2010 at 07:55:41
Specs: Windows XP, Intel Dual Core, 3GB
Tried several times and every time I do a restore the CD/DVD comes up with an I/O Error message. CD was working properly before I did the restore. I put a CD in, the light blinks about five times and then it goes dead. The laptop does not have a battery installed as my son spilled beer on it at one time and screwed up it's ability to run off of the battery. Perhaps it's looking for the battery during install and that's messing with the I/O stuff. I've uninstalled and reinstalled the CD in device manage hoping it was just a driver thing. No luck. Any ideas? or how do I assign it a new I/O to make it work?

See More: Vaio recovery yields I/O error for CD/ DVD

Report •


#1
August 18, 2010 at 09:14:33
Did your laptop originally come with Vista or Windows 7 pre-installed?

Report •

#2
August 18, 2010 at 09:53:46
... please post the "error message" and full model number ...thx


.

... Posting is provided "AS IS" with no warranties
http://a.imageshack.us/img833/1862/...
Grrrr... ...im


Report •

#3
August 18, 2010 at 10:18:35
OtheHill - Originally came with XP and that wht is being restored.

mavis007 - Error message: "E:\ is not accessable", "The request could not be performed because of an I/O device error"

Sony Vaio Model number: PCG 792L (on bottom computer sticker), VGN-FS550 is what I end up with on Sony's site??

CD/DVD is: Mats---a UJ-831Da


Report •

Related Solutions

#4
August 18, 2010 at 10:36:02
So, WinXP is currently still working but you wish to perform a system restore? While in WinXP does your CD drive work, or not?

When first booting the laptop are both your drives being configured by the BIOS?


Report •

#5
August 18, 2010 at 12:08:50
XP was working but had too much crap on it from my son's use, so I did a restore. The facrory restore is on some partition of the hard drive so I didn't need CD disks. After the restore the CD/DVD gave me the error message and now no longer works. I'm not using a boot disk so I'm not sure if it's trying to read it or not. The CD light blinks a couple of times in boot up but that's it. I assume the BIOS is trying to read the CD and that what the two light blinks are from.

Report •

#6
August 18, 2010 at 12:40:45
Excuse my confusion but I am still unclear about the current state of the laptop.

Is XP working but without the CD drive operational? If so, how is the CD drive listed in Device Manager?

Is the CD drive the original unit or a replacement?


Report •

#7
August 18, 2010 at 13:10:57
That's OK! Current state is as follows: XP has been reinstalled and now the CD/DVD gives an Error Message when any CD/DVD is put into it.The CD is listed as a Mats---a UJ-831Da in Device Manager. It just doesn't work and all I get is the previous Error Message. In Device Manager all is listed as working properly. It appears that there is a I/O conflict causing it not to respond.

Report •

#8
August 18, 2010 at 13:15:19
You may need to install motherboard chipset drivers.

What service pack do you have installed?

Post the full model of the laptop.


Report •

#9
August 18, 2010 at 13:46:01
See Response #3 for Model number
I have Service Pack #2 installed .

Report •

#10
August 18, 2010 at 14:07:43
Go to the link below and get the drivers. I suggest you download ALL the drivers listed there for WinXP and possibly for any other OS you may run in the future. Burn the drivers to disk. Manuals are also available.

http://esupport.sony.com/US/perl/sw...

You should also update to SP3 and all other updates.


Report •

#11
August 18, 2010 at 15:06:53
Been there, Done that yesterday! The two CD/DVD drivers they offer have a criteria that doesn't match the conditions I'm describing and they Warn: "Do Not Install if you don't have these symptoms". I actually did it anyway to see what would happen and all it did was give me a blank screen where data on the CD should have appeared, so I did my third recovery this morning. ARG!

As for Service Pack 3, I installed it while I was waiting for the next reply. Still get the same Error Message from the CD/DVD.


Report •

#12
August 18, 2010 at 15:23:57
I just reinstalled the chipset from Sony. Still get the same Error Message.

Report •

#13
August 18, 2010 at 15:27:24
Look at the link below.

http://support.microsoft.com/gp/cd_...


Report •

#14
August 18, 2010 at 16:27:32
Thanks. See their Privacy Statement at:

http://privacy.microsoft.com/en-us/...

and tell me if you would go for it. Unfortunately I would trust you way before Microsoft. I know that may not be saying a lot but you get the idea. Unfortunately I believe there is an I/O f__k up that is causing the whole problem. Back in the day I use to be able to mess with this I/O Error stuff and now it's gotten over my head. I believe that the battery (now missing) may have needed its I/O Address and the CD/DVD needed its own. With the battery missing the I/O addressmay have gotten tangled up and now I need to get way to assign a different I/O address to the /DVD in order to get it working again.

Does any of this make any sence???


Report •

#15
August 18, 2010 at 17:41:02
I would allow the scan. If you don't want to to that then you could try removing the upper and lower filters. See the link below. There is a manual removal method.

http://support.microsoft.com/kb/929461


Report •

#16
August 18, 2010 at 19:33:47
Thanks!
I'm going to sleep on it and start anew tomorrow.
Thanks for all the help!!

Report •

#17
August 19, 2010 at 10:35:53
Maybe the beer did more damage than you thought. You might have damaged the IDE or Sata (whichever applies, in your case) controllers on the Mobo.

It may also be as simple as a cable needing reseating. If so, it'd be more than likely the IDE ribbon cables (or SATA cables if it applies) might have developed corrosion where they connect to the Mobo. Unplug and replug them a few times to wear away any dirt/corrosion.

The IDE ribbons and/or SATA cables are a part of the I/O pathways, to and from your optical drives.

Please let us know if you found someone's advice to be helpful.


Report •

#18
August 19, 2010 at 18:17:34
Appreciate the suggestion! What gets me is that the CD/DVD was working right up until the system rebuild. I gave your suggestion some consideration before you made it but I can't find the set screw on the bottom of the laptop that is holding the CD/DVD in. That's my new quest. I agree, because on my desk tops just unpluging and repluging in the cable would reset everything and reset it to a workable connection. Now back to figuring out the removal part. Thanks Again!

Report •

#19
August 26, 2010 at 12:00:40
SOLVED! I contacted Sony service and they took control of my computer to diagnose the problem. Came to find out they just reinstalled the existing "standard" drivers in Device Manager. They said that you cannot install "any other drivers" other than the ones that are supplied in the recovery software supplied. I watched their mouse actions while they had control and here is what they did; Highlighted the Mats---a UJ-831Da drive, right clicked Update Driver which reinstalls the existing supplied driver. After that they clicked in the upper menu bar and clicked "Scan For Hardware Changes". Next they highlighted IEEE 1394 Bus Host Controllers in Device Manager and again clicked "Scan For Hardware Changes". After a sales pitch for their annual service contract I said By! and rebooted the computer and had no CD/DVD again ! I just copied what they had previously done and the CD/DVD started working again. I rebooted several times and all is still working fine now. Thanks again for all the help and effort!

Report •

#20
August 26, 2010 at 21:28:16
I don't understand. Aren't the drivers at the site I linked the correct drivers for the unit? If so, you didn't actually get them to install, for whatever reason.

Report •

#21
August 27, 2010 at 05:59:00
I don't know, and after trying everything suggested I was still getting nowhere. They said that you cannot install "any other drivers" other than the ones that are supplied in the recovery software supplied. All I know is that worked. At that point I didn't care what would work just that something would work.

Report •

#22
August 27, 2010 at 08:54:31
OK then, thanks for getting back to us.

Report •


Ask Question