USB ports not recognizing devices

Toshiba Satellite 1905-S3
March 2, 2006 at 05:50:55
Specs: Windows XP Home SP2, Pentium 4, 2.0GHz/768 MB

At some point between Monday and Wednesday of this week, my laptop has stopped recognizing any USB device I plug into either of the two ports. I last recall using it Sunday night with a GPS receiver. I went to use it again last night and it doesn’t acknowledge it’s plugged in. I then tried a USB drive with similar results. The built-in LED on the USB drive fails to light.

I noticed that on Tuesday night there is a restore point labeled “software Distribution Service 2.0”, so I tried doing several system restores including this and other dates prior, but my system won’t successfully apply any of them.

I have gone into Device Manager and checked to see if there were any problems with the USB controllers. They all reported fine. I then uninstalled them and rebooted the laptop. As it came up, it reported new hardware and reinstalled the USB controllers and USB Root Hubs. When I plug in a device, same problem.

I keep my Norton AV 2005 updated. I am religious about doing Windows Updates. I use Zone Alarm Firewall. I regularly scan for spyware. I recently ran Error-Checking (including checking the physical platters) and ran a Defrag.

At this point I’m thinking it may be hardware failure. Does anyone have any other suggestions? Any and all will be GREATLY appreciated.


See More: USB ports not recognizing devices

Report •


#1
March 2, 2006 at 06:08:46

Just to comment-
Using System Restore too many times can cause
more harm than good. After doing a restore
that does not fix a problem, then UNDO the
Restoration, and try another restore point, or
just do the UNDO.

General USB Troubleshooting in Windows XP

http://support.microsoft.com/default.aspx?scid=kb;en-us;310575
---------------------
Windows XP Does Not Detect Your New USB Device

http://support.microsoft.com/default.aspx?scid=kb;en-us;314634


Report •

#2
March 2, 2006 at 06:11:12

I appreciate the advice. However in my case, none of the restores completed successfully. At the end of each attempt it stated that no changes were made to the computer.

Report •

#3
March 2, 2006 at 10:20:35

Have you checked the status of the usb ports in the device manager? Perhaps something caused the drivers to crash. If they are reported as working properly, you could then check the voltage of the usb ports. Perhaps the motherboard has a problem providing the necessary power to the usb ports. If it was a desktop, I would suggest getting a powered usb hub to cheaply solve the problem, but using a hub with a laptop would be a pain.

Report •

Related Solutions

#4
March 3, 2006 at 05:41:48

Capt,
I did check the status of the USB ports - they report fine. Looking at the links Chuck2 listed, I saw the reference to checking the voltage and looked. I see..."The hub is self-powered.", "Total power available: 500 mA per port" and under Attached devices "2 port(s) available 0 mA Power Required" This is with and without anything plugged into the ports.

I'm still at a complete loss as to what to try next.


Report •


Ask Question