USB flash drive not recognized

June 25, 2008 at 18:11:11
Specs: xp pro, p3/sd
Hi,
I bought a 1 gig Silicon Power USB flash drive about a year ago, and never used it. Now I plug it in, and windows says, 'I see it, but I don't know what it is.'
Any suggestions?
Thanks,
John

www.cedargallery.nl


See More: USB flash drive not recognized

Report •


#1
June 25, 2008 at 19:52:35
Have you installed the latest Service Pack for WinXP?

Also check the device manager for whether the USB port is enabled.

Is there any device listed with an yellow question mark?

Also you can try to click at that device an choose update driver.
You may need the Windows CD for that.


Report •

#2
June 25, 2008 at 20:10:23
So it doesn't show in either My Computer or Disk Management?

Report •

#3
June 25, 2008 at 23:47:28
shakushinnen,

Before doing anything else, just try to put into "other" USB port of your computer.

Technology Bytes Plus
http://learnitfast.blogspot.com


Report •

Related Solutions

#4
June 26, 2008 at 08:04:59
Hi
...It's not listed under disk management or my computer.
...I plugged it into a USB port that I know works and it didn't show up.
...I don't know if I have the latest service pack installed.
...There are no yellow exclamation marks. The USB ports work.
...Windows says that it recognizes a device, but does not know what it is.
...I tried up dating the drivers, not sure if I got the right divice - no change.
...john

www.cedargallery.nl


Report •

#5
June 26, 2008 at 08:11:06
Try a right click at My Computer, choose Manage, go to the Disk Management.
Search the listed devices for your USB drive.
Maybe you only miss a drive letter.
So right click at the USB drive and change/assign a drive letter.

Report •

#6
June 26, 2008 at 09:24:06
Windows says that it recognizes a device, but does not know what it is

Maybe you need to install Silicon Power SmartKit software for your flash drive to work?

http://www.silicon-power.com/eng/su...

i_Xp/VistaUser


Report •

#7
June 26, 2008 at 09:48:06
Or you have a 1.0 USB port and this device requires a 2.0?

Life's more painless for the brainless.


Report •

#8
June 26, 2008 at 09:53:15
I don't understand how Windows can say it sees a device and it doesn't show somewhere.

I am not sure about this but the drive may be showing somehow in Disk Management but not have a letter assignment. If the drive has no formatting on it or it has some format that Windows does not recognize it may not assign a letter.

Also, how about posted the EXACT message you get when plugging in that drive.


Report •

#9
June 26, 2008 at 14:08:02
Hi,
Good idea Paul, but the smartkit says, 'no device found'
OtheHill - When I plug the drive in it says that windows has found hardware. Then it says, that it has installed the hardware, and that it's ready to go, then it says that it doesn't recognize the device.
Jennifer - You may be right. I don't know.
..... john

www.cedargallery.nl


Report •

#10
June 26, 2008 at 15:04:57
If Windows states it has installed the hardware then go into Device Manager and remove it.

It should be listed under USB devices but look to see if it is listed under drives.

If you plugged the drive in after Windows was up then next time try booting with it in.

You could also boot to safe mode and check Device manager for multiple instances of the drive. If found, remove all.


Report •

#11
June 27, 2008 at 02:51:39
Take a look at this thread:

http://www.computing.net/answers/wi...

Take note of responses 4 & 5.

You'll need to look for the PID specific to your particular device, as opposed to the device mentioned in that thread.

Please let us know if you found someone's advice to be helpful.


Report •

#12
June 27, 2008 at 08:26:05
Hi OtheHill,
I did as you suggested (actually I removed all the usb devices, because I wasn't sure which one was the flash drive) but it didn't seem to make any difference. The actual message I get from windows is, 'One of the usb devices attached to this computer has malfunctioned and windows does not recognize it.' Maybe the drive is just crap?
Hi Sci-guy. Thanks for the help. I'll look at this.
..... john

www.cedargallery.nl


Report •

#13
June 27, 2008 at 09:47:24
Try the drive on a different computer. If the drive then works try sorting things out as outlined in the thread Sci-guy linked to.

Report •

#14
June 27, 2008 at 11:52:43
"Maybe the drive is just crap?"

Of course, that's always a possibility.

Please let us know if you found someone's advice to be helpful.


Report •

#15
June 28, 2008 at 06:54:14
Hi,
I tried it in my wife's windows ME machine. Still doesn't work. I'm finished with it.
Thanks for all your help. I appreciate it.
...... john

www.cedargallery.nl


Report •


Ask Question