Solved USB flash drive not in My Computer

January 23, 2005 at 13:46:58
Specs: Win XP Home SP2, AthlonXP 1800+/768MB

I have this problem where USB removable storage devices do not show up in My Computer. The drive is recognized by the system, and I can access it through an application's Open command, but the only way to access the drive in Explorer is through Administrative Tools->Computer Management->Disk Management->Explore. If a drive in connected while the system starts up, it will show up, but then it won't dissappear if the drive is removed.

I have tried three different USB drives and they all exhibit the same problem. The drives are being assigned unique drive letters, and even if I try to change the letter to something really obscure via Disk Management, the drive still won't show up. If I boot in safe mode, the drives show up just fine, but I'm not sure how I can use that info.

The funny thing is, I had this problem a couple years ago, and somehow it resolved itself. I don't know exactly when it started happening again, but I'm thinking it might be related to upgrading to SP2. Normally I would use system restore, but the earliest restore points are after the USB problem started (my system restore was misbehaving until recently). I've tried perusing the registry, looking for relavant entries, but without knowing where to look, that isn't really getting anywhere. Any ideas?


See More: USB flash drive not in My Computer

Report •


#1
January 23, 2005 at 14:11:36

somata,
When I plug in any USB drive in and go to "My Computer" it does not show unless I hit the "Refresh" button and then it shows up.
Using a Dell 8400, Windows XP SP2
Try doing that and see if it shows up.

Let us know the outcome. please.

Ralph(jazzbo)


Report •

#2
January 23, 2005 at 18:58:19

Yeah I tried that, nothing. Basically I've tried all the stuff I've been able to find by searching this site and Google. I can only imagine there must be a software conflict or something. I wonder if certain malware could cause a problem like this. I've also noticed that explorer.exe (the desktop) now suffers "silent crashes" a couple times a day on average. By this I mean the desktop (task bar and icons) basically quits out and then reloads itself with no error dialog or anything. Sometimes after one of these "crashes" the drive will show up in My Computer, but it's very irratic.

Report •

#3
January 24, 2005 at 05:49:11
✔ Best Answer

somata wrote ...the only way to access the drive in Explorer is through Administrative Tools->Computer Management->Disk Management->Explore.

I believe this MSKB may help. Please post back to let us know.


i_XpUser


Report •

Related Solutions

#4
January 24, 2005 at 19:09:41

No, that doesn't work. In fact, if I reboot so the drive is listed, then try to change the drive letter, the drive retains it's old drive letter, gets a red question mark, and is then inaccessible. Refreshing My Computer doesn't help. Thanks for trying though.

Report •

#5
January 25, 2005 at 03:43:05

try mapping the drive, or create a short cut on the desktop. if this still doesn't work try going to device manager and see if it shows up there.

Knowledge is Power


Report •

#6
January 25, 2005 at 18:16:03

It does show up in the device manager. And as I mentioned in the initial post, the drive shows up in any Open dialog. Explorer seems to be the only app that doesn't know about the drive.


Report •

#7
January 25, 2005 at 20:51:38

Good news! I closed down all non-essential processes (and there were alot of them ;) ) and now the drives behave as they should as I disconnect and reconnect them. I don't know exactly which process made the difference, but I will post back tomorrow with the info in case anybody else ever has this problem. Thanks everybody for your suggestions.

Report •

#8
January 26, 2005 at 20:51:03

The culprit was: rundll32.exe

This process was the cause of the USB drives not showing up properly. It seems to be a normal Windows process, but it is also registered as a worm. In the registry, in HKLM->Software->Microsoft->Windows->CurrentVersion->Run there was an entry for rundll32.exe with the title "WildTrangent CDA", which I think is related to AIM games.

It seems that I'm the only one who's having this problem, but maybe there's someone else out there with this problem for which the solution is far from obvious.


Report •

#9
February 10, 2005 at 15:53:55

XPuser's is right... a glitch in XP (Surprise!)

If C: and D: are assigned to HD, and E: is a network folder, then the usb drive will not be assigned a letter. Workaround is to use letters from say S: and up for network folders.

I remapped my network drive to S: and voila.. the usb was assigned to E:


Report •

#10
February 16, 2005 at 12:20:30

somata:
My Dad has this same problem. It's interesting that I don't, though, because we have almost exactly the same computer.

We found out that if you enter the drive letter in the address bar of Windows Explorer, then it will finally show up. It would be better if if showed up in the first place.

I've been spending a lot of time searching the Internet to try to solve this problem.


" Always do right. This will gratify some people

" and astonish the rest.

" -- Mark Twain

h

K Bruce A. Johnson in Hardisty, Alberta, Canada


Report •


Ask Question