system halted and running program hanged

October 27, 2009 at 23:34:29
Specs: Windows XP, celeron
i'm running a windows xp home edition. i was supposed to open a game, then a blue screen appeared saying "system halted". the first time i encountered this problem, i thought i just need to restart my pc. then i tried to open another program (like media player, ms office, etc). it runs smoothly for a few minutes and suddenly it hanged. there's no more blue screen but any program i opened encounter the same problem.

anyone please help, or maybe any idea what's happening with my pc.



See More: system halted and running program hanged

Report •

October 28, 2009 at 09:12:45
This could be any number of things from a incompatible Driver to a Virus. What was the last thing you installed prior to this problem happening. If nothing then chances are you contracted a virus. Boot to safe mode and run a scan.

Report •

October 28, 2009 at 17:10:37
Thanks for the idea!

As far as i could remember, the last thing i installed are Turbo C, the file manager for Sony Ericsson phone, and I connected also a speaker. Before I'm only using an ear phone instead of speaker. But prior to the installation, my pc caught a win32 and trojan virus. Although AVIRA was able to removed it, I'm not sure if the virus infected the system of my pc.

If this could be any driver incompatibility, how would i know?

Or if this could be a form of any virus, how could I remove the virus and repair the pc?

Thanks much!


Report •

October 29, 2009 at 07:53:09
"If this could be any driver incompatibility, how would i know?"

You boot to SAFE MODE which loads Windows Drivers Only. Try opening the Media Player and see if it blue screens. The problem with safe mode is that it does not load drivers so no Audio and your Video looks low resolution.

Another possibility is that you have a RAM module that is failing or a hard drive that is failing. How old is this system?

Try running a bench tester to see if these systems pass...

Report •

Related Solutions

October 29, 2009 at 17:29:21
By the way, thanks for the help I really appreciate!

Yesterday, I tried booting to SAFE MODE and then ran a SCAN. AVIRA detected 4 viruses namely "TR/Dldr.WMA.wima.27". I thought I already solve the problem. I restarted the pc and load the OPTIMIZED DEFAULTS. I tried playing a game, it runs smoothly for an hour and then the same problem occured. I restarted the pc again and done a system restore but it didn't worked either. There's a blue screen again saying:

"Hardware Failure!
Contact your vendor.
System halted"

"How old is this system?"

I bought the pc 2nd hand. As far as I know it's a 2001 model and maybe it's 4 years old.

Report •

Ask Question