same windows update over and over

August 26, 2010 at 16:56:48
Specs: Windows XP, AMD Sempron / 1024 r

For about a month I've been getting the same windows update over and over. They install succesfully but within a few minutes "they are ready to be installed again".

Successful Updates
Microsoft Windows XP
Microsoft .NET Framework 3.5 SP1 Update for Windows Server 2003 and Windows XP x86 (KB982168)
Microsoft .NET Framework 3.5 SP1 and .NET Framework 2.0 SP2 Security Update for Windows 2000, Windows Server 2003, and Windows XP x86 (KB979909)
Security Update for .NET Framework 2.0 SP2 and 3.5 SP1 on Windows Server 2003 and Windows XP x86 (KB983583)

I have deleted them (add/remove programs) Googled my evenings away with this nuisance to no avails. Maybe someone might have a solution that I haven't tried yet.....LOL.


See More: same windows update over and over

Report •


#1
August 29, 2010 at 09:05:58

Microsoft Security Update has a free help-desk for security updates. Look for the Microsoft website for security updates and you should find the help desk email address. I think you will find that you will need to delete .net framework 1,2 and 3 and re-install them all but it is not simple. Someone has written a program called something like dotnetfix which will successfully delete the registry entires, so that you can re-install it. Microsoft uses this unofficial tool themselves. So get in touch first with Microcoft Spport http://support.microsoft.com/select...

Report •

#2
August 29, 2010 at 12:57:30

Thanks, will take a look.

Report •

#3
September 22, 2010 at 15:28:10

I have the same problem
what is the fix for this

Report •

Related Solutions

#4
September 22, 2010 at 15:29:52

have you found the solution for the problem

Report •

#5
September 22, 2010 at 16:13:53

It would be worth looking at the hits in this Google search:

http://www.google.co.uk/search?hl=e...

Ms Hulot's boat


Report •

#6
September 23, 2010 at 14:02:36

Seems to have fixed some issues with my problem. Just have to fix net.framework 2 sp2 now.

Report •

#7
October 10, 2010 at 04:26:25

I have had the same problem for months also. Have you found a solution and if so would you please share it with me. My email is Jerry_Griffith@sbcglobal.net

Report •

#8
October 10, 2010 at 11:02:25

griffithjerryl

Publishing your email address in open text on the internet is asking to get wadges of junk email forever. If this is the only place you have put it then remove it from the post (Edit) and instead send Pibou a personal message by clicking on his name. If your email is already publicised elsewhere it is probably too late.

Ms Hulot's boat


Report •

#9
October 20, 2010 at 16:31:50

I had the same problem and tried all the solutions on Microsoft and elsewhere. But, I have two PCs and only one had the problem - so it has to be on the PC - almost certainly a dodgy intall of .net or one of its updates. Here's how I fixed it.

1) Install the latest version of Microsoft's installer
2) Remove all versions of .Net Framework in reverse order using Revo Uninstaller. Accept all Revo's suggested changes to Registry and files on disk.
3) Reboot
4) Run the dotnet cleanup utility individually for all versions of .net Framework in reverse order. Then run it using the autmatic option for all versions!
5) Reboot
6) Run Windows update to make sure you have no relict updates to .net
7) Download and run the full install version (about 190 MBytes) of .net v. 3.5 from MS. This automatically installs v. 3.0 and 2.0 plus their SPs.
8) Reboot
9) Run Windows Update, rebooting when instructed. If an update fails, just run Update again and it should work. This happened with me, I think it's because on the first attempt after cleaning out the PC there is still some stuff left over from the previous repeating runs of Update.

This solution worked for me, suggesting that the problem is residual corruption on the PC due to a previous faulty install. Therefore, you need a very thorough clean out of all .net Framework. I have not tested .net 1.0 or 1.1 since they are obsolete and shouldn't be on anyone's machine. Hiding updates is not a satisfactory solution since it means you still have a problem on your PC.


Report •

#10
October 21, 2010 at 12:19:45

Basically, I removed all the framework application and re-installed them as in the earlier post. Seemed to have fixed the problem. I wouldn't know for sure because I had to format and re-install xp from scratch for an un-related problem. Everything is now working fine for me.

Report •

#11
October 28, 2010 at 04:28:26

Remove all traces of .Net Framework with this:

http://blogs.msdn.com/b/astebner/ar...

Then download and reinstall them all from here:

http://support.microsoft.com/kb/923100

Hope this helps!


Report •


Ask Question