run....cmd....ipconfig etc

compaq pressario m2000
August 7, 2007 at 08:48:59
Specs: Windows xp home service p, 1gb
Hi,when i go to "run"....."cmd" and type in ipconfig at the flashing cursor(with a view to check for errors on registry and "winsock") i get this come up: "IPCONFIG IS NOT RECOGNIZED AS AN INTERNAL OR EXTERNAL COMMAND,OPERABLE PROGRAM OR BATCH FILE.This comes up with the other two "codes" i type in in the same fashion!
Computer is running just fine but am curious what might be the "holdup" here,and what damamge,if any,may be occuring?
Thanks,have a good day! P SYNTH

See More: run....cmd....ipconfig etc

Report •


#1
August 7, 2007 at 09:17:06
peter, Go thru the thread at the link below.

http://www.pcreview.co.uk/forums/th...

Plenty more at the links at the search link below.

http://www.google.com/search?hl=en&...

Tufenuf


Report •

#2
August 7, 2007 at 10:59:38
Whats the output of this command:

echo %path%

Make sure that %systemroot%\system32 is listed

If it is not listed you will have to manually add it to your Environment variables in the Advanced tab in your My Computer properties.

If it is listed, and it still doesn't work, you are probably missing the file %systemroot%\system32\ping.exe. You can try searching for it to see if it accidently got moved. If you can't find it, you will have to grab it off your XP installation media.

Note: %systemroot% is an environment variable. What you will see is what path that variable points to. Such as C:\Windows.

"Computer security." — Oxymoron


Report •

#3
August 7, 2007 at 11:31:24
Tony and Tufenuf,thanks for your help...this is how i got round this,a bit involved,trial and error really.
Here are the three "codes" i was directed to use by the tech i spoke with from my DSL service to gain access START...RUN....CMD
1 netsh int ip reset resetlog.txt
2 ftp 127.0.0.1
3 ipconfig
All three garnered the message:
"'IPCONFIG' is not recognized as an internal or external command, operable program or batch file"
In the Google link Tuf sent i found this....

"I had the same problem, so I tried the following:
Type ipconfig /all. If you receive an error stating, "'IPCONFIG' is not recognized as an internal or external command, operable program or batch file"
type c:\windows\system32\ipconfig /all.
it works well with windows xp"

Well,IPCONFIG/ALL didn't help.....neither did "c:\windows\system32\ipconfig /all."

But,if you put this in
c:\windows\system32\ipconfig.
it comes up and i now have access to IP # Gateway etc(just don't use the "/all"


I created a new system restore point in case it happens again!
Thanks for your help and i hope this helps someone! P SYNTH




Report •

Related Solutions

#4
August 7, 2007 at 13:03:32
You haven't addressed or solved your issue Peter.

tonysathre gave you the answer. You need to edit your path in environmental variables to include the system32 folder.

Something is wrong with your system if that path is now missing since it is there by default.

You had to have foobarred the line
c:\windows\system32\ipconfig /all since it does and should work fine.

This message "is not recognized as an internal or external command, operable program or batch file" tells you
1. did you type the command correctly?
2. does windows know where this file is located? Apparently not.

How you would test this is GO to the system32 folder and then type ipconfig /all

You still have a problem you need to fix.

Imagine the power if you knew how to internet search


Report •

#5
August 7, 2007 at 17:04:37
He might not to have installed to C:\windows.

Windows XP Home Edition Service Pack II
[Microsoft Internet Explorer 6]
VIA C7 Esther 1500MHz [1.39GHz]
1.18GB RAM [64MB Shared Video]
40GB Samsung HD [Partitioned]
Running 24/7.


Report •


Ask Question