PC Hangs after Purple Bios

December 21, 2010 at 15:45:29
Specs: Windows XP
Hi guys I've been having issues sorting out a problem with my PC

Recently I turned on my system to be greeted by a Purple/Blue tinged Bios screen.
I can let the system do its thing, or try and enter BIOS with Del, but either way it hangs, and my monitor goes black and constantly switches between analogue and digital source modes.
Being that I can't actually enter BIOS at all I'm assuming (possibly ignorantly) that it's an issue with hardware. I'm not getting any beeps on startup at all. Power keeps running through all of this, but it seems to just hit a brick wall as soon as I get past the motherboard logo.

I've tried cleaning the dust out of my GFX card, removing and reinserting my RAM sticks, running on 1 RAM stick at a time, tried unplugging my CD drive etc, only thing I haven't tried is a replacement GFX card since I don't have a compatible spare.

Any ideas on what it could be?

See More: PC Hangs after Purple Bios

Report •

December 21, 2010 at 21:40:57
Borrow another monitor to try.

Report •

December 22, 2010 at 00:38:54
Forgot to mention, tried that as well, no dice ><

Report •

December 22, 2010 at 03:23:57
I would suspect the power supply, borrow one at least the same wattage.

No need to bolt in, just disconnect the cable from the motherboard & plug in the cable from the test power supply. Make sure the fittings are the same.

Report •

Related Solutions

December 23, 2010 at 00:48:39
After some tinkering and swapping parts around at a friends house I've narrowed it down to either my gfx card itself, or the DVI -> AVG adapter going to my monitor

Report •

Ask Question