multi port usb hub not recognized

June 29, 2009 at 08:11:11
Specs: Windows XP
hello sir
i hv just got a multiport usb hub.on connecting it, a pop up is displayed saying "usb device not recognized. no drivers found.....". Can u help me to fix it.

THANK YOU!


See More: multi port usb hub not recognized

Report •


#1
June 29, 2009 at 09:09:52
start by following the installation instructions.

then if still having an issue tell us the make and model of the usb hub.


Report •

#2
July 29, 2009 at 14:08:43
I am having this problem as well I am using a Belkin 4-Port USB. Hope you can help.

Report •

#3
July 29, 2009 at 14:11:40
Questions:

1. Did the hub ever work before?
2. Did you try all the ports on the system?
3. Is the system a laptop or desktop and what model?
4. Have you tried it on any other systems?

Richard


Report •

Related Solutions

#4
July 29, 2009 at 14:13:34
I have tried several ports on the box, none work yet they all work without the multi-port USB. I believe this started when I hooked up a new Monitor.

Report •

#5
July 29, 2009 at 14:14:39
This is a Dell Desktop computer.

Report •

#6
July 29, 2009 at 14:17:59
I just now tried the muli-port USB on another system and it does work there.

Report •

#7
July 30, 2009 at 13:36:56
Try a different USB device in your Dell. It looks like the ports could be damaged due to a voltage overload.

I recommend that customers use a self-powered USB hub to prevent damage to the systemboard from non-powered devices that draw more power than the USB controller can support.

Richard


Report •

#8
July 30, 2009 at 16:27:47
Other USB devices work fine (thumb-drives, etc) directly in the USB ports. Only the Multi-Hub device does not work on this particular box.

-Richard (as well)


Report •


Ask Question