Mouse driver corrupted(?)

July 12, 2006 at 18:50:00
Specs: Windows XP Pro SP2, AMD SanDiego 2.4, 2GB Cor

I have a wireless keyboard/mouse set at home (Model: Microsoft Wireless Multimedia Keyboard 1.1 + Optical Mouse). The other night while playing World of Warcraft, the mouse stopped responding, but the keyboard continued to work. Exiting the game, the mouse was still frozen. Rebooting, I found the mouse still didn't work. Plugging in a corded USB mouse, that one worked fine. In my Device Manager, I saw an ! next to the wireless mouse with a message that it wasn't responding. I removed the device and rebooted to let Windows redetect the mouse. Now in the Device Manager I had about 4 "HID Compliant Device"s showing up where previously there were none. Still, the mouse didn't work. I removed the wireless keyboard & mouse, uninstalled the software, and shut down. I rebooted with a PS2 keyboard and my wired USB mouse. All worked fine. I shut down again, plugged in the wireless setup, put the install CD in the drive, and booted. It detected both and proceeded with the install, searching for the driver from the web. I reinstalled the Intellipoint software. When all was done, the mouse still didn't work.

Suspecting a hardware failure, I took the mouse into work today where I have the exact same combo key/mouse. The mouse worked flawlessly.

I'm fairly certain at this point that Warcraft (newly patched, about 1 hour before the mouse crash) corrupted something. And that the relevant corrupted piece is not getting deleted & reinstalled. Looking on microsoft.com for driver information, all I find is updates to the Intellipoint software (which incidentally thinks the mouse has a Good battery level.)

Any help on what is wrong of how to fix this? I search Warcraft's technical site, but I haven't seen any description of this problem.

Other notables on my computer:
Mobo: ASUS A8N-SLI Premium Socket 939
Gfx: 7600GT
1 Seagate HDD, 1 DVD burner, using on-board audio and network. Not much else notable hardware-wise.

Thx!


See More: Mouse driver corrupted(?)

Report •


#1
July 13, 2006 at 01:53:22

Try rebooting in safe mode & removing all instances of your mouse (they don't all appear in standard mode), then reboot & see if the hardware's re-detected.

"I know that I'm mad, I've always been mad"


Report •

#2
July 13, 2006 at 17:24:24

Thanks, I'll try that tonight.

Report •

#3
July 13, 2006 at 23:53:14

No luck. I saw the exact same number of instances of my mouse (1 under Mice, 1 correct one under HID Compliant, and 6 extraneous "HID Compliant Device" that disappear when I remove the 1 Optical Mouse).

Report •

Related Solutions


Ask Question