Mouse does not work

April 12, 2009 at 10:13:20
Specs: Windows XP
Please help - I am a beginner and not tech-minded.
I am using Windows XP have been using a USB micro-mouse but wished to change to using a new optical mouse. After connecting it the new mouse although the new hardware has been recognised the mouse does not work. I have tried to uninstall the old mouse but this did not resolve the problem and now i cannot restore the old one back - again it recognises the device is attached but the cursor does not move. To add to my woes, before i made any changes i created a system restore point, however i am prevent from going back there (I have tried other restore points with the same result). Looking at other posting on the web I have seen some mention a possible IRQ 12 conflict - I do have a Synaptics PS/2 port touch pad that is using IRQ 12. Could this be the problem and if so how do i fix it? Help!

See More: Mouse does not work

Report •


#1
April 12, 2009 at 10:40:55
I presume you tried other USB ports on your PC. Those USB devices are usually recognized by XP did you get any errors?

Have you tried safe mode yet? If you can get into safe mode, go to the device manager and uninstall the usb hub. Then reboot and XP will rebuild the hub as well as probably find the new optical mouse and install it.

Some HELP in posting on Computing.net plus free progs and instructions Cheers


Report •

#2
April 12, 2009 at 11:56:13
Sorry, new to this - did try to reply but not sure it was sent.

I have tried other USB ports, and again it recognises the device but the mouse does not work

I have gone into safe mode and uninstalled hubs (and afterwards tried Human Interface Devices as well). After scanning for hardware changes it seems to pick up the devices but after restarting the mouse still does not work.


Report •

#3
April 12, 2009 at 14:13:25
Further to my previous comment, I have now managed to use System Restore (I managed to disable a conflict with my anti-virus software which had prevented this) and so I am pleased to say that I am back to where I started from.

XpUser4Real - many thanks for your help.

I would still be interested in what the problem was, but I guess I will have to be happy using my micro mouse - I do not want to cause myself any more trouble!


Report •

Related Solutions

#4
April 12, 2009 at 15:14:55
Thanks for posting back, hopefully all will be well now

Some HELP in posting on Computing.net plus free progs and instructions Cheers


Report •

#5
April 12, 2009 at 16:37:03
Was the second mouse connected DIRECTLY to a USB port or some other setup?

Report •

#6
April 13, 2009 at 06:22:09
Thanks for the reply - yes it was connected directly into another USB port.

Report •

#7
April 13, 2009 at 08:13:35
Try booting into safe mode and then checking Device Manager. Remove all mouse listings in there and reboot with the new mouse connected.

I don't see IRQ 12 as being a problem, even if it is shared. The mouse is a low power device that should be able to share the IRQ, if it is.


Report •

#8
April 13, 2009 at 08:40:18
I did try that yesterday, except for that I did not remove the Touchpad which is listed under Mice as being connected to PS/2 port. I was a bit reluctant to do this owing to my lack of knowledge. Do you think that is worth a try?

Report •

#9
April 13, 2009 at 08:56:34
I don't think you need to remove the touchpad. Is that the only listing in Device Manager for pointing devices?

I don't use laptops but I think you need to use an Fn key or something to enable an external mouse. Could be wrong about that though.

OK, I just tried connecting a USB optical mouse to my system along with my already working PS/2 mouse. The result was WinXP found and configured the USB mouse.

There is ONE cursor on the screen and EITHER mouse can move it. The USB uses no additional resources other than what the USB ports already use. My PS/2 mouse is using IRQ 12, which is the default for a PS/2 mouse.


Report •


Ask Question