Articles

Mouse cursor stuck on upper left of screen

August 31, 2010 at 17:16:51
Specs: XP pro sp3, 3gz cpu 4gig ram

My cursor is stuck on the upper left of screen. When I try to move it, it jitters wildly and returns to that spot. It behaves normally during the boot process until about three quarters of the way through when I lose control of it and it zips over to the left. I have scanned for virues and spyware and come up blank. I have used system restore trying several different dates to no avail. Also tried restoring backups as far as a month ago using my server backups. Have tried other mice too. Also deleted mouse drivers although there were no warnings of problems with them. There appeared to be a problem with the DVD drive so I swapped in a spare cd-rom drive which works fine. The system boots properly with a linux live cd


See More: Mouse cursor stuck on upper left of screen

Report •


#1
August 31, 2010 at 18:03:56

usual first step is to come up in safe mode before you start doing restore points or backup restores [hopefully you only restored system state].
what type of mouse are you using?
mouse you took off works fine in another system?

Report •

#2
August 31, 2010 at 20:38:43

Thank you for responding. The mouse works fine in safe mode and works fine from login up until almost the entire boot process is finished. Just minutes ago I finished another restore and went through the process again. The mouse worked and then zipped over once more. I have been using is a wireless usb mouse with a nano transceiver and it works fine in other computers. Other wired usb mice do the same thing.

Report •

#3
September 1, 2010 at 10:29:54

That was all done at the outset but the problem remains.

Report •

Related Solutions

#4
September 1, 2010 at 11:42:03

compare what is running in safe mode via task manager and what is running in task manager in regular bootup. What is not showing in safe mode but shows in regular is what you want to isolate.

For example how many processes are running under a regular bootup and how many are running when in safe mode.

Clearly you have a software issue if it works in safe mode and not in regular mode.

I would use a wired mouse only until the problem is solved. This eliminates electrical interferance as a possible issue with the mouse.


Report •

#5
September 1, 2010 at 13:45:27

Good suggestion. I will get right on it.

Report •

#6
September 1, 2010 at 14:11:01

Problem has disappeared on this boot up. I have had a dual monitor setup (which I guess I should have mentioned) but this time I attached only one monitor so I am now suspecting some kind of intermittent issue with the video card - perhaps overheating. I will keep you posted if you are interested.

Report •

#7
September 1, 2010 at 14:49:39

I never would have guessed a dual monitor setup would affect mouse control. This is an interesting one.

Report •

#8
September 4, 2010 at 11:53:13

The problem is back. I have swapped video cards with one from a working system and the cursor is still stuck so I guess my theory of the video card being the problem is wrong. I just want to be sure no one else with this issue is steered down the wrong path.

Report •

#9
September 7, 2010 at 08:00:39

Problem Solved! I am embarrassed to say that the cause of my problem was much simpler than speculated. I have had a digitizing tablet (Wacom) installed all along but it was hidden under some junk on my desktop and I was blindly plugging it in to the USB port during my various tests. What had happened was the digitizing pen was lying on the tablet and would occasionally get bumped around as I shuffled papers etc. This was competing with the mouse (and winning), hence the inability to move the cursor. Thank you to those who spent time thinking about my problem.

Report •

#10
October 27, 2010 at 07:10:30

Wow! I've just spent the last hour with the same problem. I'm glad I found you're post about the Wacom tablet. turns out the cleaning lady moved the pen onto the tablet last nigh.

Thanks for saving me a lot of time/money.


Report •

#11
April 9, 2011 at 06:09:20

I had exactly the same problem and couldn't figure it out. I thought I was going mad. Then I saw your mention of a Wacom Tablet. Guess what I have one too and the pen had wandered slightly onto the tablet in the top right corner, exactly where the pen was above. Thanks for posting what you did, I might be still looking

Report •


Ask Question