Large size hard disk not visible??

March 1, 2008 at 23:23:56
Specs: xp, 500

in my xp machine i installed 300gb of hard disk as an additional storage drive. (note: this is just for storage no OS installed in it)
Two HD installed C: and D: The C: for the xp OS, and the D: for the 300gb (storage) the maker is MAXTOR.
innitially the D: was visible with the full capacity. but as a result of another problem i needed to uninstall and reinstall XP service pack 2. After this, in the windows explorer the D: drive is now only showing 10MB instead of 300gb.
Moreover in the Disk Manager I can see D: with 300GB but then it shows the D: partitioned into two 128GB (showing healthy/active) and 152Gb (showing unallocated).
In this case with window explorer when i open the 10MB nothing is there (even though i have huge files there before).

I need to regain this drive fully and have it as before, how do i go about this please?. Maxtor website simply did not help with all the downloads I've made from there.


See More: Large size hard disk not visible??

Report •


#1
March 1, 2008 at 23:35:33

This might be of help

http://www.largeharddrivesupport.wi...

It's not that I can't remember things as I get older, it's just that my hard drive's full.


Report •

#2
March 2, 2008 at 09:05:48

Did the 300GB drive previously appear as only continous drive? Is there data on the drive that you need to retain? Is the 300GB drive identified in the startup screens by model number and full capacity?

Report •

#3
March 2, 2008 at 10:22:28


Report •

Related Solutions

#4
March 3, 2008 at 08:01:26

- yes this 300gb previously appeared as on whole volume (not divided!)
- all the data there must be retained, i just cant afford to loose any (before the incident started, i had over 140gb of valuable date in this drive)!
- yes it is clearly identified at the start up screen (during boot up) with full capacity! also clearly identified by BIOS with full capacity!


Report •

#5
March 3, 2008 at 08:31:39

The excerpt below is from a link by per to an article by mosaddique. Look at your registry to see if these values are present. If not, then follow the instructions below to edit the registry. BTW, you have rebooted the computer since reinstalling SP2? Also, you may still need to take ownership of the files on the 300GB drive. Look at the link below to learn how to do that.
1. To enable 48-bit LBA large-disk support in the registry:
1. Start Registry Editor (Regedt32.exe).
2. Locate and then click the following key in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Atapi\Parameters
3. On the Edit menu, click Add Value, and then add the following registry value:
Value name: EnableBigLba
Data type: REG_DWORD
Value data: 0x1
4. Quit Registry Editor.
http://support.microsoft.com/kb/308421



Report •

#6
March 5, 2008 at 06:09:52

i was able to make the following registry settings:

Value name: EnableBigLba
Data type: REG_DWORD

But on the,

Value data:

i couldnt be able to set it to:

0x1

i was only able to set it to,

1

regedit could not allow me to enter 'X' character.
will it be ok to enter just the digit '1' ?


Report •

#7
March 5, 2008 at 07:51:20

When clicking on REG_DWORD the value should automatically be entered. You may need to edit the default value after that. Below is what my string looks like for that line.

EnableBigLba REG_DWORD 0x00000001 (1)


Report •

#8
March 8, 2008 at 09:19:18

i've checked properly, my registry is now also:
EnableBigLba REG_DWORD 0x00000001 (1)

i'm now suspecting another thing. after the XP sp2 uninstall/reinstall, this 300gb automatically converts itself from NTFS to FAT format (i guess this happened during the uninstall time).
as fat format cannot read large HD like 300GB, i decided to reconvert it back to NTFS but below is the error message.
how do i successfully convert it back to NTFS?
please note that presently the data content of this R: drive is only 80GB, but when i attempt to convert it, it says insufficient disk space for the operation.
how do i successfully convert this?
the 300gb is R: while C: is the boot drive.

C:\>convert r: /fs:ntfs
The type of the file system is FAT.
Windows is verifying files and folders...
File and folder verification is complete.
Windows has checked the file system and found no problems.
10,592,256 bytes total disk space.
20,480 bytes in 5 hidden files.
4,096 bytes in 1 folders.
4,096 bytes in 1 files.
10,563,584 bytes available on disk.
4,096 bytes in each allocation unit.
2,586 total allocation units on disk.
2,579 allocation units available on disk.
Determining disk space required for file system conversion...
Total disk space: 10369 KB
Free space on volume: 10316 KB
Space required for conversion: 232722 KB
Insufficient disk space for conversion
The conversion failed.
R: was not converted to NTFS


Report •

#9
March 8, 2008 at 11:15:43

This issue is getting too convoluted.

Windows wouldn't convert your partitions to FAT. Disk Mangement should state what the file system currently is.

What you need to do RIGHT NOW is to determine if your 140GB of files is still present on this drive. They should be.

The file system has been corrupted due to the 48bit LBA issue. DO NOT mess around trying to convert or change partition size at this time.

Does it appear that any files are present on the first partition? Does the 127GB partition show in My Computer? If not, try assigning a drive letter to it from within Disk Management.

FYI, WinXP can read a 300GB harddrive Formatted with FAT32. What it can't do is format a partition larger than 32GB using FAT32. There are many different versions of FAT file system. Post back with answers.


Report •

#10
March 8, 2008 at 19:51:07

- you are right on the data content. right now i believe stongly that there is still data in the 127GB.
- the 127gb never appear on My Computer. i can see the drive R: in My Computer, but it only shows 10MB (megabyte). even though in Disk Management Console R: appears with two partitions (127gb and 157gb).
- i did assign and re-assign it with different drive letter but still the same result.

Report •

#11
March 9, 2008 at 07:36:35

When Windows partitions and formats a drive using NTFS it creates an 8MB partition at the beginning of the drive. This 8MB is unallocated. You have a 10MB partition you have done something to. I don't understand how you ended up with 10MB.

If this data is important to you then I suggest you take the safer option of attemping recovery. If you didn't format any portion of that drive there is a good chance you can recover the data.

Download Knoppix and burn the ISO to CDR. You then boot to the Knoppix disk and Knoppix may be able to see your files and can also copy them. Your issue may be where to copy 140GB of files to. You should have full control of all the features of your hardware. Burner, USB access, network access, etc. An external USB harddrive may be your easyist method. I suggest you first verify the files are accessable then deal with where to copy them to.

BTW, I say copy, not cut. The reason for that is simple. If something goes wrong during a cut and paste operation you may permamently lose that file/s. Copying large amounts of files can get cumbersome but any effort to correct the partitions could cause more damage. You may have already lost files.


Report •

#12
March 13, 2008 at 08:42:24

Thanks for your advise, i've got a new 300gb external HD, and i've been trying the knopix, even though not yet succesfully, i hope i'm hoping it will.

actually there is one more thing i'm very much worried about.
before this incident, i secured the root folder in this drive with NTFS security. in my LAN, only the group "300gb_access_ok" and the domain admins can access this root folder (in this 300gb HD) which contains all the subfolders.
the subfolders themselves simply inherits the parent (root)folder permissions.

- so when using knoppix can i take ownership of this parent folder?
or;
- is there any other way to access this parent folder?
or;
- can i copy the entire hard drive to the new USB external HD?


Report •

#13
March 13, 2008 at 09:34:02

"before this incident, i secured the root folder in this drive with NTFS security. in my LAN, only the group "300gb_access_ok" and the domain admins can access this root folder (in this 300gb HD) which contains all the subfolders".

I suggest you try to remove these resrictions while logged in as an administrator in WinXP. Moving the files or the drive MAY cause them to be locked without reecovery. I haven't any experience in this area but it sounds like the reason the files are not visable.

Why in the world did you protect those folders?


Report •

#14
March 17, 2008 at 09:19:27

the problem here is that when loged on with XP, this root folder is simply displayed as a FAT folder and not NTFS making it impossible to configure the NTFS security features 'cos the 'security tab' on this root folders property is not visible.
i'm in total mess here!
i've tried 'Knoppix' it coulnt display the real content of this 300gb disk, its only showing the same size shown by 'My computer' - i mean just 10MB (MegaByte).
Now i'm using Gparted to copy the entire drive to a new external drive i just bought. now on the 4th day the copy process is still on. though it remains a couple of GB to finish.
my concern here is (just as you mentioned earlier) that i worry if i can be able to access this root folder after the copy????

Report •

#15
March 17, 2008 at 09:32:57

As I stated before the file system can't change by itself. Are you sure you are looking at the coorect drive letter? Drive letters can be reassigned so it is possible you may be mistaken about which partition is the one with the data one it. The data may be on more than one drive or part of the data may have been lost or ALL of the data may have been lost.

What happens when you use Knoppix? Can you see all the drives and partitions in your computer?


Report •

#16
March 18, 2008 at 09:17:37

yes, with Knoppix i could see all the drives. the funny thing is that i could see and browse data on the drive with the OS (xp), but this 300gb drive is displayed only as 10MB (megabyte)by Knoppix and worse yet no data was displayed.
but talking about data loss on this drive will be a big surprise to me 'cos i doubt what will make this drive to loss its data content.

Report •

#17
March 18, 2008 at 09:29:11

When a partition size is changed the file system is automatically trashed. The data may still be somewhere on the platters but without the file system to guide you it is hard to find. If Knoppix is not seeing any files then you may need to resort to a recovery program.

You are booting to the Knoppix CD aren't you? You also need to let Knoppix do it's thing in order to access NTFS partitions. Did you see any mention of that when booting up to Knoppix? You have 3 partitions on that harddrive and if I understand your statement you only see one. The 10MB. The other two large partitions are not showing in Knoppix?


Report •

#18
March 20, 2008 at 04:16:14

looks like you didnt get it clearly.
the problem here is not partition content but harddisk content.

the 300gb harddisk IS NOT partitioned! i was using the whole drive for storage.

the problem here (once again) is that
i have 2 hard disks in this pc.

- 40gb (partitioned: winXP and winME)
and
- 300gb (no os, just for storage)

with "Knoppix live" cd as well as "CentOS live cd" i could see all the partions, file, and folders that are in the 40gb drive.
but the 300gb drive now shows only 137gb. and when i double click to open it, i only see three folders (Restore, Recycled, System Volume Information). and never see any of my saved files and folder!!!!!!!

by the way to answer your question, when the Knoppix cd is booting it displays all the drives correctly.

as you mentioned, i may end up going for recovery software


Report •

#19
March 20, 2008 at 05:49:35

You misunderstand the term PARTITION. Partitioning is performed in order to use the disk. In your case you evidently had only ONE partition.

IF the 300 GB was installed as you stated it was treated as 137GB due to the 48bit LBA constraints. When writing to a disk in that condition the remainder of the space can't be dealt with properly. Unfortunately WinXP appears to see the entire 300GB space and writes to the entire 300GB space. I don't know if ANY data can be recovered but I suggest that you try some recovery software. You can submit a new post here asking for recommendations for recovery software. I personally can't recommend any.

There may be a possibility that various repair commands MIGHT straighten things out. I am not sure about that and don't know if running them would make things worse. Although I can't imagine things getting worse for you than they are. Rather than suggest what may fix the file system I suggest you read about the commands available under the repair console. This option is normally used to repair the boot OS so I am unsure if this is even an option at all.

This is all based on the assumption that the drive WAS fully functional at the full capacity. Your attempts to convert to NTFS MAY have complicated matters, I don't know.

What confuses me is why the drive appears to be partitioned into multiple partitions. I can only guess that you may have unknowingly done that.

I think the key here is what you did to try and convert the disk to NTFS. Normally when viewing the disk from Disk Management you should see a setup like this. On the left 8MB unallocated. The remainder NTFS disk type basic. Look in Disk Management and tell me how your partitions are seen there. Is the 10MB NTFS?


Report •

#20
March 22, 2008 at 10:07:35

thanks so much for all your support OnTheHill, i finally got it!!!!!
i got solve this problem with
'TestDisk' - cgsecurity.org
precisely the problem here was that the Bootsector of this 300gb was corrupted. and i guess it was when i did the xpsp2 uninstall. with this TestDisk i was able to replace this disk's bootsector with its 'backup bootsector'
this was after a really-really-really-really big struggle, determination and time !!

Report •

#21
March 22, 2008 at 12:40:26

Glad to hear you solved it. I have had a similiar issue when Ghost imaging software has failed. Ghost creates a virtual partition on your drive and makes it the bootable partition. Had to use WinXP rapair console to fix the partition. I thought about running that by you but wasn't real sure what you had. I am still in a quandry as to why you had a 10MB partition. As I stated, the default is 8MB when using NTFS. Did it revert back to the 8MB unallocated?

One other thing to note for the future. Either slipstream SP2 into your WinXP CD version or completely disconnect that 300GB if you need to reinstall again. If you are insterested in slipstreaming post back for links.


Report •

#22
March 27, 2008 at 10:09:03

sorry for late reply,
yeah please tell me more of the slipstreaming - i'm interested!
regarding the reason for the 10mb on the disk, it did ofcause revert back to 8mb. the reason why it initially appeared as 10mb i dont know exactly.
again, many thanks!!

Report •

#23
March 27, 2008 at 10:43:45

ericcc

nLite is probably your easiest method to slipstream SP2. I am including a couple of other links for your review so you can understand the why and wherefore of slipstreaming. I have use Pauls guide in the past and it does work. I have also used nLite and it too works. It is all about what makes you the most comfortable.

One thing that may not be clear to you when starting is that you MUST be using a computer that is running an OS based on the NT kernal. WinXP is preferable but Win2000 or Win2003 are also acceptable.

http://www.download.com/nLite/3000-...

http://www.winsupersite.com/showcas...

http://www.msfn.org/articles.php?ac...


Report •

#24
March 27, 2008 at 19:33:18

FYI:

Here's a simple solution for the LBA problem.
http://www.48bitlba.com/enablebiglb...



Report •

#25
March 27, 2008 at 19:48:03

Cuffy, that won't help in this case. The drive will only be seen as 137GB until WinXP is installed. At that point WinXP SP2 can be installed and 48bit LBA will be available. The harddrive will be partitionsed into two partitions and you would need to use a parttion manager to combine them. Slipsreaming is the best solution.

Report •


Ask Question