Articles

Help! Evil file won't let me delete

August 16, 2005 at 18:08:26
Specs: Windows XP, 1.5 ghz Pentium M 512


Okay I won't go through the whole story but basiclly I have a file with a invalid file name that I can not delete. It is a AVI and has a very long file name. It seems to be a partial download from LimeWire. It has a write protected/file in use error when I try to delete. It won't even give me the option to select delete in my right-click menu.

So far I have tried the following:

Tried Deleteing in Safe Mode (same error)

Tried Using KillBox (cannot select/cannot delete folder containing file, tried again in safe mode same error)

Tried DelinvFile - This is a Program to delete through dos short name (says file cannot be found even though I can find it in the popup window)

Tried Same program using UNC method instead of short name (says error 206)

Tried GiPo@MoveOnBoot utility (says it is going to delete it but won't on reboot, tried again in safe mode same error)

Tried Hijack this "delete on reboot" function in safe mode (invalid file name error)

Tried deleting the Default Registry String in:
HKEY_CLASSES_ROOT\SystemFileAssociations\.avi\shel lex\PropertyHandler (it would not let me delete, says unable to delete all values) Someone told me if I delete it, I can delete the file no problem.

I have no idea what to do now! I consider you guys the best on internet. I've already posted at three forums and those were all the suggestions. Your my last resort.

Thanks for the time!


See More: Help! Evil file wont let me delete

Report •


#1
August 16, 2005 at 18:54:29

See if any of these help.

Delete "Unremovable" File
http://www.xs4all.nl/~laar2002/tweak/delete-unremovable-file.html
http://www.theeldergeek.com/delete_undeletable_file.htm
http://www.softwarepatch.com/tips/howto-delete-xp.html

1) Open a Command Prompt window and leave it open.
2) Close all open programs.
3) Click Start > Run and enter TASKMGR.EXE
4) Go to the Processes tab and End Process on Explorer.exe.
5) Leave Task Manager open.
6) Go back to the Command Prompt window and change to the directory the undeletable file is located in.
7) At the command prompt type DEL where is the file you wish to delete.
8) Go back to Task Manager, click File, New Task and enter EXPLORER.EXE to restart the GUI shell.
9) Close Task Manager.

Or,

Delete undeletable files in XP
http://home.tiscali.nl/rogier666/windows/wintricks.htm
FILES & FOLDERS

1) Close all open programs.
2) Open a Command Prompt window.
3) Close Explorer.exe from the task manager (ctrl-shift-esc), leave Task Manager open.
4) Navigate to the folder with the undeletable file(s) in the command prompt window with the cd command.
5) Delete the file with del filename.ext
6) Reopen explorer.exe from the taskmanager.

=====================================

You cannot delete a file or a folder on an NTFS file system volume
http://support.microsoft.com/default.aspx?scid=kb;en-us;320081

===================================

Delete/Modify "Locked Files"
http://www.windowsxpatoz.com/cgi-bin/performance/index.cgi?answer=1050716977&id=1036282433
The XP bug that sometimes locks files (mostly AVI's) can be overcome quite easily. When XP refuses to delete/modify a file; simply jump into the command prompt (Start>Run>"cmd") and modify the file from there. Windows-DOS seems to work around this bug. No need to wade through complex procedures for this one.

Or ,

http://personal-computer-tutor.com/abc3/v31/vic31.htm

Or,

InstallFile
http://www.webgrid.co.uk/fileman_4.html
http://www.kraftig.com/InstallFile/index.htm
http://www.jkh.no/jkh/installfile/
The new version of InstallFile quickly solves the common problem of replacing or deleting locked files. You cannot run your favorite application. One of the dlls suddenly has the wrong version number, probably as a result of the installation of another program. After searching the disk and CD-ROMs you find the right version, only to discover the wrong version cannot be replaced. At this point, typically you would reinstall your favorite application, perhaps loosing a lot of customized options. Sounds familiar?
The solution:
Use InstallFile to replace the wrong version file with the right version file. And it works!

Or ,

Swiper
http://www.webgrid.co.uk/fileman_5.html
http://www.broccolisoftware.com/Products/ProductCategories/FreewareTools/FreeUtilities.asp
When a file is open by another user it is locked and impossible to delete, move or replace. This is a problem when trying to update executables and database files which could be locked for long periods while other users work on them.
The Swiper application can be set to monitor a file, local or on a network. Swiper minimizes to the system tray while it waits for the file to become available. As soon as the file is unlocked, Swiper can delete, replace or move the file to another location.

=====================================

FreeFile will free a file by finding the process that holds the lock, and allow you to terminate it.
http://www.skrubbeltrang.com
Requires the .Net Framework! Download it at:
http://msdn.microsoft.com/library/default.asp?url=/downloads/list/netdevframework.asp

FreeFile will run on 98, ME, NT4, W2K, XP and W2K3

Cannot delete file: Access is denied -
* "Make sure the disk is not full or write-protected and that the file is not currently in use."
* "There has been a sharing violation."
* "The source or destination file may be in use."
* "The file is in use by another program or user."

- These are typical error messages you get when you try to delete a file that is locked by a process.
But which process has locked the file? Use FreeFile to automatically find out which process is locking your file, and free the file by ending the process.


Report •

#2
August 16, 2005 at 18:55:19

Try this

Tt Lanfire
MSI K8N Diamond
AMD64 3000+'Venice'
1gb pc4400
OCZ Powerstream 520w
6600GT
WDCaviar 160gb sata
WDCaviar 160gb sata

;~}


Report •

#3
August 16, 2005 at 20:06:40

I'm trying those tricks, but when I'm at the command prompt it says

Delete is not a recongized internal or external command.


Report •

Related Solutions

#4
August 16, 2005 at 20:11:17

Okay i'm an idiot, its Del not Delete.

Okay I did it trying the whole filename. And it said it didn't find it, it only put lik the first 10 character in the error message.

So I'm guessing I need the dos short name, but how do I find that out?


Report •

#5
August 17, 2005 at 10:27:10

should be able to right click on file and go to properties and get the file name

Please keep us updated so we know if we helped you or not.


Report •

#6
September 4, 2005 at 00:19:22

I had the same issue with trying to delete a file with a really long filename.

If you read "Cause 4" from this doc, it will give you a clue on how to delete it.
http://support.microsoft.com/?kbid=320081

All I did to access the file and delete it was to move it up the file hierarchy. Probably best to go all the way up to C:/

If you cannot move the file itself...try moving the folder that it's in.

Good luck!


Report •

#7
September 8, 2005 at 23:42:28

Ya, I tried just about everything........


The only thing that worked was to reinstall limewire, direct the download folder to where the older one was, and under the LimeWire browser part of the program, delete the files.......

Maybe limewire left some kind of registry guard on it when I uninstalled......

But I was able to delete the other files from it with also pretty long names.....


Werid....


Report •


Ask Question