File does not have a program associated

April 18, 2010 at 23:44:39
Specs: Windows XP Media Center SP2, 1.66Ghz/1Gb

I've been battling some nasty spyware over the weekend that infected a customer's laptop and the system is now infection free.

Since removing the infections (Windows Defender 2010, AntivirusDoktor2009, etc.) I can no longer open Internet Explorer from the shortcut automatically pinned to the Start Menu. I can open it from the desktop but if I open it from the start menu I receive the following message.

"This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel."


I know how to create associates in the folder options menu but I don't know what kind of file type this shortcut is since it works if you use the desktop icon.

I have removed Internet Explorer by means of "Add/Remove Windows Components" and reinstalled it but that didn't have any effect.

Any help is greatly appreciated.


See More: File does not have a program associated

Report •


#1
April 19, 2010 at 00:41:14

baodun66, I suspect the nasty affected ONLY the shortcut and all you need do is delete it and create a new one. If that doesn't do the trick, IE opens most things or find a 'what opens what' list @:
http://filext.com/
HTH.
Ed in Texas.

Report •

#2
April 19, 2010 at 06:59:52

baodun66, Try the LNK File Association Fix at the link below. If that doesn't work try the EXE File Association Fix


http://www.dougknox.com/xp/file_ass...

Tufenuf


Report •

#3
April 19, 2010 at 17:12:07

Ed:
I would delete the shortcut if I could but it's the one to your internet browser that windows XP automatically creates from the browser you choose under "Taskbar and Start menu Properties" > "Customize". I've removed it and re-added it with no effect. I also can't find that specific shortcut ANYWHERE in windows explorer so I don't know what extension it is to reset. Other shortcuts and .exe's work so I don't know what to reset.

Tufenuf:
Thanks for the links but neither of those files helped. Both imported correctly and I still get the same message after a reboot.


Report •

Related Solutions

#4
April 19, 2010 at 18:25:54

baodun66, Try this:

Click Start>Run then copy & paste or type in:

regsvr32 /i shell32

Click OK

Note that the spacing is important

Restart your computer.

Tufenuf


Report •

#5
April 19, 2010 at 19:05:51

Tufenuf, I got a successful completion message but after reboot it still doesn't work.

Report •

#6
April 19, 2010 at 20:03:06

Right click on the working shortcut, choose properties, High Light entry in 'Target" , right click and select copy. Do the same for the shortcut in the start menu, except clear the target area and click paste, then OK. After that it should work.

You have to be a little bit crazy to keep you from going insane.


Report •

#7
April 19, 2010 at 20:17:45

Fingers,
That's the first thing I tried... what makes this so hard is that when I right click, the only options that pop-up are:
-Browse the internet
-Internet Properties
-Remove from This List

I installed firefox and if it is set as default browser, the shortcut works but as soon as I change the default back to IE, it quits working again.


Report •

#8
April 19, 2010 at 20:23:13

baodun66, Go into C:\Program Files\Internet Explorer and right click on iexplore.exe and select "Pin to Start menu". If it won't let you you may have to first click the Start button, right click on the current pinned Internet Explorer icon and select "Remove from this list" than try the above again.

Tufenuf


Report •

#9
April 19, 2010 at 20:30:37

Tufenuf,

That works as a band-aid but doesn't actually fix the issue... it just skirts around it. If you ever come across a fix for this, let me know.

I suppose that will have to do since I have to have this system back to the owner tomorrow morning.

Thanks for all the help!


Report •

#10
April 19, 2010 at 20:46:24

baodun66, Go thru the thread at the link below. There appears to be the solution about half way down the page.


http://www.tomshardware.com/forum/7...

Tufenuf


Report •


Ask Question