Articles

Failed to create d3d device

July 17, 2005 at 05:55:03
Specs: Windows XP Pro, AMD Sempron 1.8ghz

Hello. My computer has been working fine since i got it for christmas last year. Suddenly yesturday i noticed alot of my games are not working, when i try to start them the "Failed to create d3d device" pops up. Now i have the latest drivers for my card and i have the latest direct X. I have ran the DXDiag video tests as well. My hardware accleration is to full also (i have tested all the other modes of accleration too). What confuses me is that several of my newer games still work (The Sims 2 being one of them. Can anyone help me?

See More: Failed to create d3d device

Report •


#1
July 17, 2005 at 06:17:34

I have not had that problem but saw where a person that did de-activated D3D and re-activated it in dxdiag, it worked for him??

Report •

#2
July 17, 2005 at 14:04:22

Thanks for your reply. Unfortunaly that didt work for me. I am continuing to try, if i find out i will post the solution here.

Report •

#3
July 17, 2005 at 16:21:03

Problem solved!. It seems Nvidias latest drivers cause problems with the Geforce FX 5200 cards (not sure about other cards). So i got the older ones :)

Report •

Related Solutions


Ask Question