External Harddrive Won't Mount

December 14, 2007 at 03:55:53
Specs: Windows XP Pro SP2, AMD Athalon 64 Processor
I installed an external hard drive (80gb Seagate installed in a Nexxtech enclosure) and everything worked fine. I was able to access the drive and the data on it. Shut everything down for the night and now I can't get access to it again.
It shows up in Device Manager as DMI Ultra Disk Drive USB Device but no longer shows up in My Computer or Disk Management. I've uninstalled, unplugged, restarted, re-installed; everything I can think of or have been able to find on various forums.
I already copied over the data I needed off of it so I wouldn't mind just reformatting it. How can I either force this to mount or reformat it?


See More: External Harddrive Wont Mount

Report •


#1
December 14, 2007 at 09:49:56
Have you tried it on another computer?

Report •

#2
December 14, 2007 at 10:01:27
"Shut everything down for the night and now I can't get access to it again".

Did you simply shutdown the computer, or disable the USB device first? If you write to the USB drive and then immediately shutdown, the drive may not have finished writing before power was interrupted. While it isn't necessary to disable any external drive prior to shutting off your computer it is a good idea to give the drive a little time. Windows is supposed to prevent this behavior from happening. If the drive is corrupted that would be the most logical reason why.


Report •

Related Solutions


Ask Question