Explorer.exe asking for Internet access?

Self build / N/A
May 24, 2009 at 19:32:06
Specs: WinXP, 1.5Ghz, 256MB
Can someone tell me why Windows Explorer (files and folders) is asking for internet access everytime I start it? I see no reason why this program should ask for internet access. My firewall keeps reporting this since I upgraded to DSL service. Does this program phone home every so often? Anyway, I've been denying it access. My ISP is Verizon. Is this a Microsoft thing or a Verizon thing?

See More: Explorer.exe asking for Internet access?

Report •


#1
May 24, 2009 at 20:00:00
Is your firewall ZoneAlarm?

i_Xp/VistaUser


Report •

#2
May 25, 2009 at 05:08:36
http://www.mvps.org/winhelp2002/hos...
Blocking Unwanted Parasites with a Hosts File

Report •

#3
May 25, 2009 at 16:31:14
Windows Explorer does not phone home and should never go online in it's own right.

Hosts file can only block the address it is sending to, which you've already done with your firewall. Hosts is not the right way forward in this situation.

Maybe something got screwed up with your DSL upgrade. Viruses and spyware are also possible - try Malwarebytes.

some other bloke...


Report •

Related Solutions

#4
May 25, 2009 at 19:02:04
Derek, check out the link below to see for yourself how ZA (& possibly others) caused Windows Explorer to access the internet.

http://www.google.com/search?source...

i_Xp/VistaUser


Report •

#5
May 26, 2009 at 06:19:25
Thanks everyone! I will access the links provided to learn more. So, my denying access was the right thing to do?

Report •

#6
May 26, 2009 at 06:41:59
XpUser
Thx for the correction - strange but true it seems.
One hit shows that I even had it myself (on W98 way back), which I'd completely forgotten.

CyberDude
If there are no obvious side effects (such as internet access), I reckon it is reasonable keep Windows Explorer access denied.

some other bloke...


Report •

#7
May 27, 2009 at 20:38:11
Thanks Derek! I scanned my system but found no threats. I then updated SpywareBlaster to the latest version and enabled all protection. I set ZoneAlarm to deny access for Windows Explorer and to remember that setting. All OK. Thanks to all for your input!

Report •


Ask Question