EncodePointer /explorer.exe failure

eMachines
January 5, 2008 at 21:51:11
Specs: Windows XP Home SP1, 384 MB

i get the error "the procedure entry point EncodePointer could not be located in the dynamic link library KERNEL32.dll" whenever explorer.exe loads, which is when Windows starts up and when explorer.exe crashes (which it now does quite a bit) and restarts itself.

what's the way to fix this without reformatting? i've looked around and seen mentions of replacing explorer.exe and/or kernel32.dll but if they're both in use, how? and where to get the replacements if my machine never came with a Windows installation disc?

i think this problem came about from myself canceling the explorer.exe process and restarting it myself as to get around the annoyance of Windows saying a file/folder i want to delete is in use, when it's not. it was either that or a virus/whatever that i might've got at the same time.

also, startup programs appear in the taskbar when they've been set not to, and none of their normal settings are being saved.

help? PLEASE?


See More: EncodePointer /explorer.exe failure

Report •


#1
January 6, 2008 at 05:19:38

if you can get service pack 2 downloaded and installed, or a disk to install, it should fix it, since the sp2 is a whole new setup of system files and eplorer

Report •

#2
January 6, 2008 at 06:57:24

Have you tried a System Restore?

Life's more painless for the brainless.


Report •

#3
January 7, 2008 at 04:44:57

i actually did upgrade to SP2 which solved half my problems, then downgraded back down since i've never liked SP2 and it froze while copying the files over, for 12 hours until i just gave up on it and crashed my pc. kind of dumb but i had no other choice, so now Windows won't even start.

i had Ubuntu on a disc from when my hard drive failed me a year ago, so i put that in and used the sudo mkdir blah blah thing to let me access my Windows hard drive so that i could at least transfer all of it off to an external hard drive, but it's not even showing up! i don't know if it's because of the failed SP1 downgrade or because unlike last year, i have my hard drive split into 3 partitions. should i make a new subject/question for this now? :[


Report •

Related Solutions

#4
January 7, 2008 at 04:46:34

ps. i didn't have system restore turned on x_x

Report •


Ask Question