Articles

DirectSound Error in XP

Dell/ Precision 360
June 25, 2007 at 20:54:51
Specs: XP Pro SP2, 2.8Ghz/1GB


Hi,

I'm having a problem with some kind of application called "DirectSound". I ran a quick google search online and it says DirectSound is a part of DirectX so I'm assuming that maybe the problem lies with DirectX.

Anyway, what happens is this:

I've been playing around in this 8-bit music tracker program called "FamiTracker" for about a month. And now all of a sudden when I launch the program it gives me this message that says:

"DirectX Error
Error: DirectSound initialization failed!"

I click OK and then the typical Microsoft Error thing pops up saying:

"A Famicom/NES music tool has encountered a problem and needs to close. We are sorry for the inconvenience"

I checked to see what data this error report contained and aside from a ton a code that I couldn't copy to my clipboard there was a section at the bottom that said:

"The following files will be included in this error report: C:\DOCUME~1\Daniel\LOCALS~1\Temp\92a1_appcompat.txt"

After viewing that I usually just choose not to send the error report and the program then closes on it's own.

I've checked for solutions online and I've noticed a lot of other people seem to have DirectSound issues with Winamp. I checked my Winamp and it works fine. This is the only program I've had this error with. All other sound and music stuff works fine.

Any help in resolving this issue so I can get back to making chiptunes would be stupendously appreciated :)

If you need any more information, let me know. And, as always, thank you in advance!


See More: DirectSound Error in XP

Report •


#1
June 26, 2007 at 00:42:19

Kenson, sorta a shot in the dark... Could your driver have become corrupted? Replace it with a fresh download just 'cuz? Double check and be sure you allow 'Active X'? Perhaps something changed it?
HTH.
Ed in Texas.


Report •

#2
June 26, 2007 at 14:37:55

Dear Ed,

Thank you for trying to help. I'm totally stumped on my own with this one. Replacing the driver sounds like a worthy shot.

Thing is, I'm a little lost on how to properly go about doing that. I always thought that any driver needed changing was done so through the Device Manager. But I don't see a "directsound driver" listed there. And I've been having trouble locating a place online to download a directsound driver.

I know it's probably something really basic, but if you or anyone else could offer some quick guidance I would be eternally grateful.

Thanks again


Report •

#3
June 30, 2007 at 10:12:42

Well, I found a solution. I'll post it here in case anyone else ever runs into the same problem (though I very much doubt it.)

I ran regedit to open the registry editor and from there I located the FamiTracker registry folder. After opening that up I looked for the "Sound" key folder and deleted it. That set everything back to normal.

Thanks to all who tried to help,
Kenson


Report •

Related Solutions


Ask Question