cdr4_xp.sys causing blue screen

Dell Dimension L1000r
May 27, 2008 at 17:09:08
Specs: XP Home SP 2, pent 3 384MB RAM
I recently tried to update my Roxio CD program to a newer version. It seemed to be working fine. When it restarted to complete the installation, I got a blue screen. I had to restart in safe mode to get the computer NOT to restart with the screen so that i could see the error.

This is what I am getting :

DRIVER_UNLOADED_WITHOUT_CANCELLING_PENDING_OPERATIONS

and it is in cdr4_xp.sys

My cd rom drive works in safe mode, but not at all when I restart regularly. I tried system restore to before the roxio install, but that didn't help.

I tried to install/uninstall Roxio while in safe mode but it will not allow me, says that the administrator has disabled installation (or something of that sort) However, my account is an administrator account. I tried under the other administrator account that you have to choose from when starting in safe mode also, and it still wouldn't work.

My CD drive is LG CD-RW CED 8120B - But I am pretty sure that it is not the drive, as it does show up in device manager. the error message there says that the driver is corrupt or missing.

Should I try to find that file and replace it? I did try to pull it off of the Roxio install disk while in safe mode, but it still did it. As long as that .sys file is in the system32/system folders, I get the blue screen.

Any suggestions?

Laughter makes the world go 'round, so stop your btchin', you're slowin' it down!


See More: cdr4_xp.sys causing blue screen

Report •


#1
May 27, 2008 at 17:41:29
It would help to know what versions of Roxio you are working with. Look at the link below.

http://support.microsoft.com/kb/813339


Report •

#2
May 27, 2008 at 18:17:35
Check out this
It looks promising.

Report •

#3
May 28, 2008 at 06:59:29
Oh, sorry. The original version was Roxio Easy CD Creator basic 5.2 and the newer version is 5.3.4.21 and that is what is installed now, at least, that is what it says in the about box when I start the program.

Yes, I got the system compatibility error, but only with my original version. When I tried the update, I didn't get that. I am just wondering if my problem was that I should have uninstalled the original program first.

Laughter makes the world go 'round, so stop your btchin', you're slowin' it down!


Report •

Related Solutions

#4
May 28, 2008 at 07:05:24
Did you also install the packet writer included with Easy CD? I amight be wrong about this but I think the packet writer included with Roxio 5 has compatibility problems with WinXP.

BTW, Roxio 6 is fully functional with XP sp2, including the packet writer.


Report •

#5
May 28, 2008 at 07:06:20
Aegis

I will give that a shot, however, I don't think there is an update for my version, because it's outdated. I had an update at one time for this product, and I think I might still have it saved....I'll give it a shot :) The only problem is that I cannot uninstall it, it will not allow me to because it says it needs the cd, and without the cd drive working, that won'twork and it won't let me uninstall in safe mode

Laughter makes the world go 'round, so stop your btchin', you're slowin' it down!


Report •

#6
May 28, 2008 at 07:10:29
I want to upgrade, but don't have the money to right now. I used the cd that came with another dell system. It has worked to update another system, just not mine. So I am not really sure what the packet writer you are referring to is.

Laughter makes the world go 'round, so stop your btchin', you're slowin' it down!


Report •

#7
May 28, 2008 at 07:16:47
well, tried the updates, and no luck. It won't even run the program, I get an error message:
NTVDM CPU has encountered an illegal operation CS:055a IP 0395 OP 63 72 69 70 74 Click close to end the program

there are 2 buttons, close and ignore. the error comes up several more times if you click ignore.


Would it work to find a copy of cdr4_xp.sys online and copy it to the proper folder?

Laughter makes the world go 'round, so stop your btchin', you're slowin' it down!


Report •

#8
May 28, 2008 at 07:36:14
In Roxio 5 I think it was called Direct CD. In Roxio 6 it is called Drag to Disk.

Go into My Computer> program files> Roxio. See if there is a folder nemed Direct CD or something similiar.


Report •

#9
May 28, 2008 at 07:53:24
oh, ok, yes Direct Cd is installed. I used it before with the older version. Do you think the updated version I installed might be creating the issue?

Another idea to uninstall,
I know there are programs for virtual drives...to copy a cd to a virtural drive so that you don't have to actually use the CD ROM...I have had that before but I forget what the program was called...anyone have any ideas on that? I was thinking I can find that and make a virtual copyof the roxio cd to use for uninstalling?

Laughter makes the world go 'round, so stop your btchin', you're slowin' it down!


Report •

#10
May 28, 2008 at 08:12:10
If it were my system I would try a back door approach to this issue. I believe Direct CD may be the cause of your issues. Look at the link below. It applies to Roxio 4 but I believe the packet writer is the same. With version 5 Roxio reworked the packet writer and renamed it Drag to Disk.

I would simply delete Direct CD from within the Roxio folder and run a registry cleaner. I can't guarantee this will work. I'm just saying what I would do.

CCleaner has a pretty good registry tool included. You could download CCleaner prior to deleting Direct CD.

Your other option would be to perform a system restore.

http://support.microsoft.com/kb/285910


Report •

#11
May 28, 2008 at 10:04:10
system restore won't work. I already tried that and it still caused the same issues.

I already have version 5 of roxio, and it is called direct cd.

I will download CCleaner, as I meant to anyway. I have been looking for a good registry cleaner, and have had several suggestions. JV16 was another that I have been trying.

I will go ahead and make a restore point and then go ahead with your suggestion and see what happens.

My only problem is that if I delete this, what should I do about the cdr4_xp.sys file? I need that for my drive to work, right?

Laughter makes the world go 'round, so stop your btchin', you're slowin' it down!


Report •

#12
May 28, 2008 at 12:32:28
JV powertools 16 was a good cleaner. However you need to be careful using it as it hasn't been updated in years so it may remove things you don't want removed.

My point with Direct CD was that BOTH versions 4&5 were problematic. You stated you had Direct CD working with WinXP? Are you sure it was installed?

Take a look at the link below for cheap CD Creator.

http://www.softwaresurplus.com/Guar...


Report •

#13
May 28, 2008 at 14:25:39
Yes, I had it installed and I used it almost every day. (we have a business from home and I used to to save contracts/estimates on cd) It always worked fine for me.

I deleted the direct cd directory and cleaned the registry. didn't work.

I also tried the virtual cd to try to uninstall roxio, but it doesn't work.

I found a free cd burning program and installed it but still nothing. I have no extra money at all right now, so even a cheap program wouldn't work.

how would you go about manually uninstalling a program? is it possible? Do you think that Roxio would help? I don't think they offer support for version 5...maybe I should email them and try....

I would just dump everything because it really needs it but I am only on dial up and to reinstall everything will be so hard because of the downloading updates and such. (I have sp2 installed, and my win xp cd won't allow me to do a repair install or anything like that unless I uninstall sp2, which right now I don't want to do.

What about sp3? I ran windows update a few days ago and it said that I should install it. Maybe that would help?

Laughter makes the world go 'round, so stop your bitchin', you're slowin' it down!


Report •

#14
May 28, 2008 at 17:42:15
The program is $12.

I wouldn't recommend installing SP3 at this time. Does your computer have an AMD processor in it? If so, you definately don't want to install SP3. If it is an Intel processor you are probably OK to install SP3. I don't know if it would help your problem or not.

You could try to add that file. Don't think it will harm anything. Find the file at the link below.

http://www.cdrom-drivers.com/driver...


Report •

#15
May 29, 2008 at 07:12:45
It's a pentium 3, intel.
I tried a new file, and it didn't work. still got the same errors.

Would there be anything in msconfig that I could uncheck to start? I already checked the start up items and there is nothing there?

Laughter makes the world go 'round, so stop your bitchin', you're slowin' it down!


Report •

#16
May 29, 2008 at 08:40:14
You could Google each of your listed items in Task Manager to see which ones may be related to Roxio.

Do you have the Dell restore disks? It may be easier to restore to factory state.

The CD drives are dependent on ASPI Layer Drivers. Burning programs install their own versions which can sometimes cause problems. Look at the link below for more info on ASPI layer drivers.

First I suggest you try removing the CD drive/s from within Device Manager and rebooting. Nothing to be lost at this point in trying that.

One other item that has helped others with lost optical drives is deleting upper and lower filters. I have not found the need to ever do that and some sites recommend against wholesale deletion. However it apparently has worked for some.

http://aspi.radified.com/


Report •

#17
May 29, 2008 at 08:50:06
I tried removing the drive several times with the same problems.

Well, after all this, I found a fix.

http://support.microsoft.com/kb/314060

yes, it required deleting upper and lower filters.

I also found a bunch of references to a program called roxizap.exe It supposedly deletes all the parts of Roxio that their uninstall doesn't. I can't seem to find it though, am waiting for someone to email me back to see if he can send it to me.

I so appreciate your help and sticking with me through this all :)

Laughter makes the world go 'round, so stop your bitchin', you're slowin' it down!


Report •

#18
May 29, 2008 at 09:02:01
I mentioned the filters in my last post. Below is a link to the Roxio-zap download.

http://www.softpedia.com/get/Tweak/...


Report •

#19
May 30, 2008 at 12:07:41
I had done the filter thing before I did see your last post :) And I did get the Roxio-zap download from the person I had contacted. Everything seems to be working fine now. I just need to make sure the burner still works, but I don't have any blank disks right now, so I will have to wait. I really need to get some stuff off my d: drive, as I am tired of getting the "disk space low" message. (but I don't want to disable it either, so...)


Thanks again. I am glad to see someone stick with a problem to the end and help solve it. Thanks!

Shanna

Laughter makes the world go 'round, so stop your bitchin', you're slowin' it down!


Report •

#20
May 30, 2008 at 12:19:44
Sounds like you solved it yourself but glad to do what I could.

Report •


Ask Question