CCleaner won't update

System manufacturer / System name
May 23, 2010 at 07:47:34
Specs: Microsoft Windows XP Professional, 1.746 GHz / 1535 MB
Could anyone help with this little problem, please? I recently installed FireFox as my web browser but this may or may not be relavant. At the same time my PC became infected by the Olmarik virus and this was cleaned remotely by the kind folks at Eset, who provide the NOD32 Anti-virus programme that I use.
Now I am finding that all the 'clickable' parts of the CCleaner page will not work - including the updating. I have tried re-installing the programme twice but the problem still persists. I would be grateful for any suggestions as to what I could try now. (Polite ones only, please!!)

See More: CCleaner wont update

Report •

May 23, 2010 at 08:46:38

Report •

May 23, 2010 at 10:22:20
Dear XPUser4real.

Yes, I had downloaded the current version before all this started. The two re-installs I've done are within the last 24-hours and are the latest version. I have checked on my wife's PC that all is OK on the website itself (and it is) and that she is not only able to download the CCleaner updates but also the links on the page to Piriform i.e. the green pear in the top right-hand corner and the CCleaner logo in the top left - neither of which work on my computer. We both use the same operating system (XP) and other sites which offer updating seem to work on my PC.

Warmest regards and grateful thanks for taking the trouble to respond - Peter

Report •

May 23, 2010 at 10:30:22
you may still be infected. Try running these free cleaners and remove all they find:
1- Malwarebytes
2- Trojan Remover
3- Hitman Pro

If trojan remover and hitman pro run clean, uninstall them as they are only fully functional for 30 days.

PS: Check this out- Eset vs Avast

Some HELP in posting on plus free progs and instructions Cheers

Report •

Related Solutions

May 23, 2010 at 11:02:34
Thanks a lot. I've just found out that Belarc Advisor won't load in, either.


Report •

May 24, 2010 at 15:06:59
I hope this might help anyone who comes across a similar problem. Following advice given above I installed Internet Explorer 8 again and then deleted FireFox from my computer. Lo and behold, everything sprang back into life and all the hyperlinks that had previously ceased to function now work perfectly again. Thanks to everyone who took the trouble to answer my call for help! Peter

Report •

Ask Question