Access denied while trying to del?

February 7, 2005 at 13:17:32
Specs: Windows XP SP1, Athlon 64 3500, 1 GB Mush

While trying to delete some old files that I don't want anymore, I get an error that says "Cannot delete *filename*: Access Denied.

Please make sure that the disk is not full or write-protected and that the file is not currently in use."


I ctrl+alt+del and close any processes that might be using that file, I shut down all other open programs, and it still won't let me delete it. I tried to delete it from Command Prompt, and I get an Access Denied message.

I've tried to go into safe mode to delete it, but then I can't even get into more than half the folders on my E: drive (Access Denied to the folders)!!!

I have no clue what's going on with this "Access denied" crap. I'm the only one who's ever used this computer, and I'm sure I didn't restrict myself from certain things.


See More: Access denied while trying to del?

Report •


#1
February 7, 2005 at 13:20:06

Download moveonboot, and it;'ll do it for you next time you restart. The other access problem is a bit odd, alright. have you ever dumped your user profile and created a new one?

faster, better, MORE!!


Report •

#2
February 7, 2005 at 14:51:26

Well that program is alright, but I have a lot of files that I need to delete, and some folders that I can't access. Moveonboot won't let me delete folders. :( And no, I've never had a different user profile.

Anyone else have a suggestion?


Report •

#3
February 7, 2005 at 15:12:14

Make sure you have ownership of the files/folders and also check that the files aren't being initiated at startup - check msconfig and your startup folders, all of them including the all users one.

If the files are being used it should tell you which of the files is being used in the error meesege that appears. If not then it is an access permissions issue. All worth considering!

- H.I.T -



Report •

Related Solutions

#4
February 7, 2005 at 16:09:10

How exactly do I make sure I have ownership of the file?

And no, the files aren't being initiated at startup.


Report •

#5
February 7, 2005 at 16:13:41

This may help.
http://support.microsoft.com/default.aspx?scid=kb;en-us;243514

Report •

#6
February 7, 2005 at 16:52:55

Wow I got so excited when I saw that page! I thought for sure you found the answer to my problem. But, that didn't work. I tried both methods they say on that page, and both ways I still get an "Access denied" message.

Btw, I've ran AVG Anti-virus fully updated. No viruses that are causing the problem.


Report •

#7
February 7, 2005 at 16:58:53

I tried the shift+del method, and I still got the same error message.

I tried to do it through command prompt using "rd /S" and I got an error that said either "Directory not empty" or "File could not be found"


Report •

#8
February 7, 2005 at 19:30:48

To take ownership rt click-properties-security and select the proper checks.
Try opening the folders-click edit-select all and rt click and moveonboot all of them.

Report •

#9
February 8, 2005 at 09:17:38

Right-click folder > Properties > Security > Advanced > Owner.

- H.I.T -


Report •

#10
February 8, 2005 at 12:59:10

There was no "Owner" tab/button/label.

Under Advanced, there is.... "Archive and Index attributes" and "Compress or Encrypt attributes"

I'm guessing I do have ownership of it. Still no luck. :-(


Report •

#11
February 8, 2005 at 13:39:40

Yeah, evidently you have ownership or you would have the option. it has me stumped. All I can think of from here is to do it from a dos boot and you probably have ntfs file system so I think there is a ntfs boot some where but don't recall. Will get back if I find it.

Report •

#12
February 8, 2005 at 13:45:18

Link to Barts PE disk. You have to create it. It will then boot into the front end of XP and allow you many operations you can't do in windows.
http://www.nu2.nu/pebuilder/

Report •

#13
February 8, 2005 at 13:47:04

Your hitting the Advanced button in the General tab - you want the SECURITY tab, THEN advanced > owber tab.

In here it should say ~ Current owner of this item:
and underneath it will have a name. If that name is not your account name...it needs to be. Pick your name from the box below (if listed) and click apply and ok - be patient here. That should sort it.

- H.I.T -


Report •

#14
February 9, 2005 at 15:58:46

Ok guys, thanks for all of your help but I found a solution on my own while I wasn't even trying to!

Well, I was sharing a bunch of files with my brother over the home network, and I ended up sharing my entire E: drive. I go and try to screw around with these files that I've been having trouble with and I can now access it! I deleted everything I didn't need.


Report •


Ask Question