Network - poor performance even on

September 23, 2008 at 01:13:08
Specs: Vista Home Premium 6, Q6600/4Gig
HI Guys

im trying to get HD stuff to stream and its jerky as hell so, in order to rule out the network I dropped back to a x-over ethernet cable with the server direct to a device (I tried a laptop and a HD media player). However, this was still jerky. So, next step, I put a free FTP server on the server and then tried to connect via FTP and copy over the file. The best I could get was 11meg a second.

For the life of me, in my simple view of things, all seems good so, I thought i'd ask the experts for tips. Please take a quick look at the specs below and see if you can see why I'm only getting 11meg and im open to suggestions!


Desktop(Ftp server)->x-over->Laptop(Ftp client) = 11meg a second
Desktop(Ftp server)->homeplug(bedroom)->Laptop(Ftp client) = 4meg a second

Ouch. So none of these are particuly good considering the direct connection with nothing in the middle.

The PC's specs:

Intel Core 2 Duo E6850 @3.00
Ram 4gb
Vista Home Premium 64
Boot disks SATA1: 2xWD Raptors (stripe)
Storage SATA2: 2x Hitachi 1TB disks (stripe)

Important bit?:

Generic Marvell Yukon 88E8056 Ethernet Controller

Settings below, any ideas?


[*]Flow control - TX/RX Enabled
[*]Interrupt Moderation - Enabled
[*]IPv4 Checksum Rx Enabled
[*]Jumbo Packet - 1514 (smallest option, cant disable)
[*]Large Send Offload (IPv4) - Disabled
[*]Max IRQ per sec - 10,000
[*]Priority & VLAN - Priority and VLAN Disabled
[*]Receive Buffers - 512
[*]Speed & Duplex - Auto-Negotiation (tried forcing 100/full)
[*]TCP Checksum Offload (IPv4) - Tx & Rx Enabled
[*]Transmit Buffers - 256
[*]UDP Checksum Offload (IPv4) - Tx & Rx Enabled

The devices connect at 100meg but I can't see where to see if this is Full duplex or not.

So, any ideas? I'm really struggling.... and very confused.

Thanks in advance!

this is my sig


See More: Network - poor performance even on

Report •


#1
September 23, 2008 at 19:25:51
Well first off - Have you tried updating the driver to fix? Did a driver from Windows update get installed (tried rolling back if thats the case to original driver) that could be causing this.

2. You have a gigabit NIC on the desktop, do you have one of the laptop as well? - A gigabit switch would give you up to 1000meg connection between each, since you are looking to stream HD

3.Have you tried another NIC in your PC to ensure its not a system setup issue? A USB NIC would make it testable on both a Desktop and Laptop - and also a know working cable is always good to know too.

Thanks for any input.


Report •
Related Solutions


Ask Question