Internet browsers do not work

Acer / Aspire 5720z
February 6, 2009 at 13:34:04
Specs: Windows Vista, Dual core, 2GB
Ok I posted a question about this before but
didn't get the problem solved. I am on the
verge of loosing my sanity over this issue
it's that bad.

Basically, all of my web browsers, firefox,
Chrome, IE just won't display any webpage
after 2 hours or so, or maybe, 30 minutes.
It's a real pain, nothing will load
whatsoever and more to the point they all
seem to crash, Firfox stays in the system
processes, taking up 100,000+ KB of RAM and
WILL NOT end. I can't imagine what is going
wrong, I have changed from Zone Alarm to
Comodo just to see if it helps any of the
settings but the problem persists. Answers
from the previous time I asked didn't lead me
to the problem because I couldn't find
anything wrong.

The internet problem has also stretched to
other services, such as update programmes for
games that now "cannot connect to the
server". If anyone has any idea on how to
sort this out please tell me, and if you can
email me instead as it's near impossible to
load this web site and email and msn are the
only things working;


See More: Internet browsers do not work

Report •

February 6, 2009 at 13:50:44
telnet port 80

"Best Practices", Event viewer, host file, perfmon, antivirus, anti-spyware, Live CD's, backups, are in my top 10

Report •

February 9, 2009 at 11:26:39
Ok so what would be the best way to solve
this? I have looked around on Google and the
things I find do not work, any kind of
command prompt doesn't work and site's that
offer to check if you port is open can't even
detect it.

Report •

February 10, 2009 at 16:50:14
"any kind of command prompt doesn't work"

What do you mean? Did you try telnet port 80?

"Best Practices", Event viewer, host file, perfmon, antivirus, anti-spyware, Live CD's, backups, are in my top 10

Report •

Related Solutions

February 11, 2009 at 11:11:43
I opened command prompt and entered various
commands revolving around telnet port 80,
none of which worked. An example of something
which did work would be;

or >exit

They are basic but they worked, nothing to do
with Telnet 80 did which is rather annoying.
Are there any specific ones I should check?

Report •

March 12, 2009 at 18:10:24
Did you find a solution to the disconnecting browser problem? I am having the same issue. All internet services work except browsers! I can do ping, traceroute, download files, etc, etc but all browsers fail! firefox/ie7/opera/chrome

vista home premium - either wireless or wired. Other computers are fine through the same router . . .

jefro: I do know how to telnet a port. I know how to telnet into a remote host. Please explain "telnet port 80"
Telnet uses port 23 and probably will not function through a different port

Report •

March 30, 2009 at 05:21:16
I strongly suspect TinglyJon is experiencing ZoneAlarm-related problems even if ZA has mostly been removed. I've seen the same thing recently on an Acer laptop with Windows Home Basic SP1 (build 6001) - Firefox works fine for a few minutes and then times out or the tab just crashes. Initially, at least Firefox got some conclusive result, even if negative, from the windows socket connection: everything worked apart from connecting to web servers. After upgrading to the latest ZoneAlarm, the tab hangs indefinitely instead - as Jon says the firefox.exe process cannot be killed by Task Manager (or even Process Explorer).

You get a very similar result using IE7, including the irrecoverable crashing, but IE7 does allow you to start multiple instances. Each new IE window works for a while, then again can't connect. This is irrespective of wired or wireless; DNS resolves fine; you can ping from the command line and indeed telnet to port 25 (SMTP email) with no problem; it only affects port 80 and so must be a process-bound TCP-level (level 4) firewall issue. Windows Network Diagnostics (when Windows is in the first state, i.e. refusing port 80 connections, rather than hanging) reports the error as ' is not set up to establish a connection on port "World Wide Web service (HTTP)" with this computer', which is a very obscure way of saying it could ping home but not open a port 80 outbound connection. In the second state, it usually won't find the error at all.

Yes, of course you can telnet to port 80 (HTTP). In Vista, annoyingly, you need to install the telnet client under Control Panel > Programs > Windows features. Just try "telnet 80". If there's a delay and a connection error there is a connectivity problem or firewall filtering; if it returns to the command line immediately, then the connection is refused Google's web server isn't running (unlikely); if the screen clears, you are connected to HTTP and should in theory be able to type commands like "GET / HTTP/1.0". The result for me was in case (i) (before the ZA upgrade), the connection was refused; (ii) (after) telnet hung on connecting just like the browsers. But again, it can work for up to 20 minutes before this happens.

Windows Update has caused previous problems with ZA (see e.g. so I enabled Windows firewall logging (Control Panel > Administrative Tools > Windows Firewall with Advanced... > Monitoring > properties > public > configure).

I even got the same effect on port 80 TCP connections in Windows safe mode, but then the IPsec Policy Agent, Windows Firewall, and ZoneAlarm's True Vector Internet Monitor (vsmon.exe) are still running. Then I recalled similar problems just affecting port 80, on OSs with ZA as far back as Windows 98. See for fuller information.

So the issue becomes how to remove ZoneAlarm (including vsmon) altogether or alternatively remove Windows Vista altogether (needless to say, the laptop works fine under Ubuntu).

After running the ZA uninstaller, the laptop has been online for over an hour with no problems. You might need to reinstall and uninstall until TrueVector no longer loads on bootup. Comodo is the best Windows firewall I've seen for advanced users, free or commercial.

Report •

Ask Question