Graphics card software will not load

Dell / Dimension xpsgen5...
September 8, 2009 at 13:05:42
Specs: Microsoft Windows Vista Home Basic, 2.53GHz/768 RAM
I have new graphics card installed, ATI Radeon HD 2400, 64bit. I had already deleted old card. Now under device manager,other devices, it shows 2 things, ! unknown device, ! video controller. I still can't get the software to load from disc. Is my graphics card still unrecognized and is the old one still showing up? Any help is appreciated. Thanks again for being patient with my problems. lol

See More: Graphics card software will not load

Report •

September 8, 2009 at 13:13:24
slow down for a bit...
in device manager expand Display adapters and post the name of the card given there ( you will now which card is installed properly)
then insert the disk with drivers for the other one and install it...
i`ll give you more information if neccessery

Report •

September 9, 2009 at 07:00:52
If you have not properly uninstalled the software for the previous graphics card and removed it from Device Manager before installing the new one, then the ghost shadow of the previous card may still be lurking somewhere in Device Manager. But you may not be able to see it in Device Manager.

Follow the article:

to be able to see nonpresent devices.

Once you find your previous non-existing graphics card in Device Manager, remove it from Device Manager and install software for your new card.



Report •

September 9, 2009 at 12:57:27
Good link suatcini.

This is almost always the result of not taking a few minutes to read the instructions for installing any device. End result, at best, is a thirty minute job takes much longer.


Our patience is fine; let us know how you're getting along with this.


Report •

Related Solutions

Ask Question