Format hard drive

Acer Aspire one ao751h-1346 netbook
September 27, 2009 at 01:53:07
Specs: Windows Vista, 1.6GB/512DDR2

I was using windows Vista on my notebook. After about a year I wanted to reinstall as it was becoming slow.

However, when I inserted the disk it did not boot from it when the computer started.

I went into the BIOS and set the boot priority to give the DVD top priority. However, that didn't work.

Thinking it was the disk, someone gave me their version of windows vista. However, this didn't boot from the DVD. However, I was able to install windows vista from exploring DVD and double clicking setup.

However, the problem started when I tried to restart. I get this GRUB menu and the computer says it fails to boot.

I want to reformat my entire hard disk and start again.

Many thanks for any support

See More: Format hard drive

Report •

September 27, 2009 at 03:12:49
Not sure i understand the question. Are you asking how to get it to boot of a DVD? If you got a disk with your laptop it would most-likely use a partition on your hard-drive which if you formatted, most likely doesnt exist anymore. I did not know that Microsoft had suddenly resorted to using GRUB rather than the ntbootloader but if they have the thing i most suggest is downloading an image of Ubuntu or another operating system, or bootable partition manager, (Hyrens Boot Disk is my favorite choice but im not entirely sure thats legal ;) ), then i recomend getting that disk back off your old pal and shoving it in the system. It might be an upgrade edition of windows vista however, in that case you would need to install an older windows operating system first (Not mentioning any illegal download websites of course *cough**cough*. To install an older operating system first you would probably need windows 9x or greater, on that page is a version of 98, if you are posting on the internet i beleive you should probably be able to download an image and burn it to disk -- or to floppy; whatever your choice. Goodluck, and if you want me to further elaborate just post here :P

EDIT:: Almost forgot, a way around the no-boot from DVD would be to load up off a floppy drive. If you dont have one you could probably just get a cheap one for a couple of dolarz' second hand. If it was external (as it is a laptop) and connects through USB you might like but then how would you load off a floppy to use a floppy drive? Dunno, so thats for you or someone else on here to work out :P

Report •

September 27, 2009 at 04:33:50

Thanks for your reply.

I think the disk my friend gave me was not a genuine windows vista. As it is Windows Vista Dark Edition.

Yes you are correct the GRUB is linux boot loader. I thought that was strange as well.

I have tried to put in windows XP that came with my other machine. Which I know works, however, it doesn't boot from this disk. However, the light does go on in the DVD so it is trying to read from the DVD

After that I get this displayed:

Booting 'Windows Vista'

Vista Loader 2.1.2

fallback 1
find --set-root /bootmgr

Error 17: file not found
	Booting 'Windows NT/2000/XP'

fallback 2
find --set-root /ntldr

Error 17: File not found
	Booting 'Enter Command Line'

Boot failed! Press any key to enter commadn line

If I press any key I get the following:

GRUB4DOS 0.4.3 2007-3-13. Memory: 639k / 1011M. CodeEnd: 0x3D7BC

[Minimal BASH-like line editing is supported. For the first word. TAB lists possible command completions. Anywhere else TAB lists the possible completions of a device/filename. ESC at any time exits.]


Many thanks for any advice

Report •

September 27, 2009 at 05:32:52
Hmm.. This is nothing like ive ever experienced before. And yes, Your friends edition of Vista sounds very in-genuine to me :P

If the computer you are explaining is the one the product part of your name in your first post (Im not entirely sure on this websites workings :P) then your computer doesnt have a floppy drive, i kind of guessed it wouldnt. What you are experiencing probably has something to do with the fact that your computer is a netbook and probably wasnt designed to have an OS install, to be honest im surprised it runs vista as that is an incredibly memory hungry OS :P. Your best chance would be, as i suggested, to use a partition manager such as the one on hirens boot disk. This boot disk is an ISO that can be burned onto a CD. Selecting hard drive tools should get you what you are after, it looks like what has happened is you have formatted but left a very modified version of the grub MBR on your hard drive. You should also be able to boot another OS off your card-slot also.

(The most relevant are the first and last links but all 3 might help a little :P)

This site might be of use (I understand it but i dont expect everyone to)

This one also,

And this one might help with the vista boot loader

Other than that i cant really provide you with much more than a good luck. :P

Report •

Related Solutions

September 27, 2009 at 08:08:53
What machine are you having the problem with? Is it the Aspire One AO751h listed in your thread header & is the -- CPU/Ram: 1.6GB/512DDR2 -- part of the machine's actual specification?

Windows 7 News!

Report •

September 27, 2009 at 14:38:13
I kind of suspect that you either used a home made DVD to install or more likely is the way the laptop came from the factory. They use many ways to recover your system, one is a standard bootable dvd along with ways that require you to press a F key at boot time to access a hidden partition. I think you made that part of your system now.

Playing to the angels
Les Paul (1915-2009)

Report •

September 27, 2009 at 14:39:09
Many thanks.

My mistake was when I set the boot order, I didn't save it to the BIOS.

I found my old XP pro installation disk. Put that in and re-boot.

So now I have managed to install XP Pro without any problems.


Report •

September 27, 2009 at 16:10:42
The simple answer is that the version he is using is a pirated Vista Ultimate and it starts on a Grub menu. It's a pretty common version around here. I beleive though that if you install SP1 the system stops working.

Home Page

Report •

Ask Question