dell inspiron 530s problem

Dell Inspiron 530s desktop (intel pentiu...
August 11, 2010 at 09:31:08
Specs: Microsoft Windows Vista Home Pre., 1.995 GHz / 1471 MB
I have a dell inspiron 530s It will not power up at all the light on the psu is green and there is a amber light on the motherboard on all connections are tight. It started starting up on its own then it would not shut down then it went to shutting itself off and now it does nothing. It will not power up at all all I get Is the two lights one green on psu and one amber on mobo

See More: dell inspiron 530s problem

Report •

August 22, 2010 at 12:56:33
im thinking its a dead or rather dying PSU or certain components are not getting enough power. but usally you get through post and begin startup.
fist the simple things: try plug-in the tower into a wall socket on its own i.e. not via a multi extension.
do you have another power cable available - to be fair if it is the cable then it shouldn't do anything.

try removing everything that isnt essential. start with usb devices and any secondary hdd's dvd drives etc. so that your left with the bare minim.
i am unsure if your comfy with doing this as you comment regarding connections can either mean youve checked your mobo connections or you just mean the power cable into the pc. if you mean the latter then please say so i dont want to give you brief advice for something your not comfy with and you go tinkering with things and risk messing things up further when it could be something simple(ish).


Report •
Related Solutions

Ask Question