Installing Java 1.7 on Windows NT 4.0

August 19, 2014 at 12:58:39
Specs: Windows NT 4.0
I need to install Java 1.7 on Windows NT 4.0. I understand Java 1.7 is not supported on Windows NT. So I need to find a way around it so i can use its features and functions.

Currently my NT is running Java 1.4. I need to install a proprietary software on Windows NT that requires Java 1.7.

When I run an Java 1.7 installer on a command prompt, it returns with a message "Access is Denied". My user has Full Control Permission and Ownership of the installer.

I tried to copy a installed copy of Java 1.7 from XP to NT. When i ran Java -version, I still get "Access is Denied".

I don't have this problem when I run Java 1.4 installer. The Java 1.4 installer runs just fine.

Is there a way around to install Java 1.7 on Windows NT? Any help will greatly be appreciated.

Thank you.

See More: Installing Java 1.7 on Windows NT 4.0

Report •

August 20, 2014 at 03:13:21
Seriously, you need to consider installing a newer version of Windows to overcome such issues. NT 4.0 is around 18 years old!

Report •

August 20, 2014 at 04:30:45
Sometimes the impossible just can't be done. I'm afraid that your needs just don't correspond with the real world.

Is there any reason why you are still running NT 4.0?

Report •

August 20, 2014 at 09:35:53
We have an software product that has to run on Windows NT 4.0 because some of the our customer bought it 10-12 years ago when we were still running NT. Because of older hardware we can't upgrade to latest Windows.

We are trying to upgrade our software and it needs Java 1.7. Unfortunately Java 1.7 does not seem to run on NT.

Report •

Related Solutions

August 20, 2014 at 18:47:54
You state that you have to run NT4 because of older hardware, yet your software needs a version of Java that has to run on a newer version of Windows...isn't there any way you can run the software on a newer machine (one that can handle at least XP) and possibly run NT4 in a VM on it? If not, isn't there any way to separate the two entirely?

"Channeling the spirit of jboy..."

Report •

August 21, 2014 at 10:13:58
We already have the new generation products with newer hardware that runs Windows 7 where we are able run our software with latest Java. That is not a problem.

The problem is we cannot upgrade the older hardware that some of our customers are using, hence we have to stick with Window NT 4.The older hardware cannot be upgraded to newer Windows at all. VM is out of options.

Report •

August 21, 2014 at 12:02:46
From what I understand NT 4 is not compatible with Java any later that 1.4. I don't think installing version 1.7 is a viable option. You will have to make your development decisions based on that, difficult though they may be. The issues involved with newer software on an older OS tend to be more serious than with older software on a new OS.

Report •

September 4, 2014 at 11:39:21
You can't run Java 6 or 7, but you should be able to run Java 5 on NT 4.0, and that may be new enough to execute the software and necessary functions. "Unsupported" and "doesn't work" aren't the same.

I highly recommend installing the Service Pack (SP6) before continuing:

message edited by sdfox 7

Report •

Ask Question