Windows can't find my CD drive

July 1, 2005 at 14:56:40
Specs: Win Me, AMD Athlon XP 3200+ / 1GB

Hi all,
I've got an Abit NF7 motherboard that I think might be going bad, but I'm not sure if it's that. Recently my Windows Me has not been able to detect that I have a CD drive. The BIOS sees the drive just fine, and I can use the drive when I boot up with a Windows Me boot disk (floppy). It's just that Windows can't detect it. I also checked in the Device Manager and there's no hint of it there either.
I also tried swapping out the drive with an old one that I also know to be working, but Windows was unable to see that one either, though again the BIOS did.
I have 2 hard drives on one IDE cable and on the other IDE I have the Windows boot drive as master and CD drive as slave. I've tried switching the cables and the IDE slots the drives are plugged into with no difference. I've also scanned my computer for viruses and it's clean. I even tried reinstalling Windows (had to copy the CD to my hard drive using the CD drive of another computer on my network) but it still has no idea I have a CD drive. Data & power cables are all secure.
The only thing I can think of that caused this is at one point I got a BSOD saying something to the effect of my computer detected a mix of 32-bit and compatibility-mode drivers and halted the system to prevent corruption. After that I had no more CD drive as far as Windows was concerned, and also my hard drives are going a lot slower. Device Manager shows there's a problem with the primary & 2ndary IDE controller drivers but doesn't say what. I didn't have any luck reinstalling any of the drivers that came with the motherboard CD.
Anyone have any idea how I can get Windows to see my CD drive, and possibly also get my hard drives back up to full speed? This problem is really starting to drive me crazy!!


See More: Windows cant find my CD drive

Report •


#1
July 1, 2005 at 15:06:25

If the IDE controllers are showing a problem then the system will not detect devices on it properly.

First Update the IDE drivers from the motherboard manufac... web site. (chipset INF)

Second I would check to make sure the system did not add the good old NOIDE in the registry.

Start --> run
regedit

In the left pane make sure My Computer is selected.

Click edit ---> find
Type in NOIDE
click find

If a entry show up delete it, and reboot the system.



Report •
Related Solutions


Ask Question