operating system not found on hp pavilon 7920

September 26, 2009 at 13:32:06
Specs: Windows Millenium Edition
I bought this computer with windows ME from a person who said that it had a problem (no operating system found), so I attempted to fix it with a windows ME bootdisk and I get four options (Help) (Boot with CD-ROM support) (Boot without CD-ROM support) and finally ( Minimal boot), and part of the problem is that either one I choose it takes me to command line, so I insert the Windows ME installation CD in he second CD-ROM drive and write on the command line "A:\> E:\Setup.exe and the analyzing step of the installation starts and ends up saying that it can't create a directory because the HDD has not been partitioned, so I write in the command line "FDISK" to create a partition and when it loads it says "no fixed disks present" so I'm like scratching my head from frustration, and I really want to fix this computer. (floppy disk is not an option)

Thank you very much for any responses given!!

See More: operating system not found on hp pavilon 7920

Report •

September 26, 2009 at 13:36:29
I also ran scandisk.exe in command line and it said there were no probems in harddrive C.

I only have one harddrive and data loss is not a worry to me so anything will help here.

I can enter the BIOS with F1 and everything with ease.

Report •

September 26, 2009 at 15:39:01
I don't understand. You say you boot up with a bootdisk but then end your posting by saying 'floppy disk is not an option'????

Fdisk can't report 'no fixed disks present' while scandisk can successfully scan the fixed disk. If you did run a scandisk it must not have been on the hard drive. Your bootdisk may have created a ram drive at the first available drive letter. If there was no hard drive seen or no valid dos partition on the hard drive, that ram drive would have set up at C: So the scandisk was done on the ram drive and not on the hard drive.

Open the case to make sure the hard drive cable is in good condition and firmly attached. Check in cmos/bios setup to make sure the hard drive is correctly identified there. But likely the drive is bad.

Report •

September 26, 2009 at 20:22:59
I booted with the CD-ROM drive and it booted and it installed
diagnostic tools from boot disc to "C" drive and the problem is
that Drive "C" is usable but is not detected on the BIOS; it said
"no fixed disks present" and I cannot create a partition to do the
rest of the stuff , I did not touch
the BIOS by the way, and thats as far as I've gotten, oh ya
and I saw there is no master hard drive in the BIOS
configuration list.

and about the scandisk, I typed in "ScanDisk /all" in
command line and it scanned drive "C", drive "A",Drive "E" and drive "D" , it
said mainly in the "C" drive scan that there were no errors and
no structure errors.
I have a western digital caviar hard drive 30GB

two cd-rom drives and floppy drive are also on the computer I
talked about

I've set the pin configuration on the hard drive to master drive
and other configurations and nothing happens

NOTE: Drive "E" and "D" are CD-ROM Drives

virtual Ram drive is drive "A" which is the floppy drive but I'm booting through cd-rom
so drive "C" must be the hard drive.

I run the boot cd through cd-rom drive "D"

I want to do whatever it takes to fix the computer.

Report •

Related Solutions

September 26, 2009 at 21:07:37
I believe your right DAVEINCAPS I bought his computer old and
it might be broken after all, by the way I found a drive restore
utility from western digital that allows me to reset the hard drive
and automatically creates a partition and sets it to FAT32 as if it
came from the factory. so I'll see if this works and i'll respond as
soon as possible.

Report •

September 26, 2009 at 21:14:59
here's the trouble shooting website for my hard drive:


Report •

September 26, 2009 at 21:59:08
When it said it was loading the diagnostic tools to drive C: that meant it was loading them to the ram drive as I suggested above. (They always load to the ram drive.) The ram drive is a temporary drive created using part of your ram. It's not an actual physical drive. The ram drive uses the first available drive letter. If there's no hard drive or no dos partition on it then there's no pre existing C: drive so the ram drive sets up there.

In cmos/bios setup you need the IDE controllers enabled and the drive properly identified. The IDE controllers are usually enabled by default and the drive is usually specified as AUTO so they're probably OK but that, the cable connection and jumpers are the only things that could keep a good drive from being seen.

In the jumper diagram in your link the jumpers shown horizontally are spares and don't affect the setting. If your drive is the only one on the cable then the default setting is 'no jumper', or at least, no vertical jumpers set.

If bios settings, cable and jumpers are OK then I think you can assume the drive is bad.

Report •

September 27, 2009 at 08:20:33
ok so I ran the tool I found and it doesn't work; it says "drive error, no hard drives found" so i'm going to
try the classic hard drive tool program. I'll also try cleaning
the ends of the 40 pin connection and the other stuff in the
computer even though nothing is dusty inside. maybe there's
something stuck in one of the pin holes and its causing the

and another thing, I'm confused whether drive "A" or "C" is the
virtual ram drive because if I use either, they both work as command lines, so might there be two ram drives?

NOTE: drive A is the floppy drive, but it is not in use, I never use it,nothing is inside the floppy drive.

and remember I counted a total of 4 drives during the disk

do you think buying a new western digital caviar 30GB hard
drive for $15 should fix the problem? because I heard they
come formatted and partitioned so I can readily install an
operating system (OS). the computer hardware store is right around my corner, literally.

oh and one more thing, everything else like the 128MB ram is ok.

I paid $20 to buy the computer I'm fixing, LOL. I got it because I wanted to practice fixing this type of problem, this is the most common problem with some peoples' computers when they reformat their hard drive.

Report •

September 27, 2009 at 13:29:59
When booting from my 98 OEM cd (I don't have a regular ME disk) it sets up a ram drive at A: and nothing at C:. When using the bootdisk the ram drive sets up at C: (with no hard drive attached). You appear to be getting something at both A: and C: You might do a dir a: and enter and a dir c: and enter and see what files show up. So yeah, there may be 2 ram drives. Maybe the same stuff is loading in both places. Also type path and enter. That shows what drives or folders are searched if you enter a command that isn't on the current drive.

As far as replacing the drive, an exact replacement--another 30 gig WD--might work best if you have the restore disks as sometimes they expect the original drive. Otherwise whether it's partitioned and formatted doesn't matter as it's easy to do with the fdisk and format commands. As a matter of fact it's usually best to do that on the computer in which the drive is to be used.

If you don't use a 30 gig drive you can probably use any IDE drive up to about 120 gig. Above that a bios needs to be '48-bit LBA compliant' and I'm not sure yours is.

Report •

Ask Question