IE6 won't install after recovery

Hewlett-packard / PAVILION
December 19, 2009 at 13:53:59
Specs: Windows Me, 633 Mhz/255 Mb Ram
I used the recovery disc. Now my CD and Labtec webcam work however I can't get internet explorer installed. Some of the components won't install . There is an old thread about this which has been locked so I had to start a new one. In the old thread I said finally installed it but this time after following the instructions it didn't work. Here's what happened. You'll probably have to look at the old thread to understand (#47365) This was the main instruction that worked for me when I understood how to do it.
For the "unable to install all components" issue with IE6SP1 in WinME, try

Go to My Computer - Tools - Folder Options - View:
- Select "Show hidden files and folders", click Apply - OK

Create a folder named "Old uninstall".

Go to folder C:/Program Files/Internet Explorer/Uninstall Information.

Now Edit - Select All - Cut all files.

Open "Old uninstall" folder and paste the files.

You will now be able to install all the troublesome components.

If everything works as expected, you can delete the "Old Uninstall" folder
and the files you moved.
I pasted the 'uninstall information' files into the "old uninstall" folder which was still there after I used the recovery disc ( I didn't reformat). When I tried to install IE6 again it didn't work. I got the 'some components won't install message again. I tried again by deleting the 'old uninstall' folder first , created a new 'old uninstall', went searching for the 'uninstall information' files but couldn't find any to copy and paste into the new 'old uninstall' folder I created. Guess I got rid of them when I deleted the first 'old uninstall' folder.I deleted that folder from the recycle bin also. I tried to install IE6 again anyway with the same results. I am using other browsers but I want outlook express 6 and someone has said I might not be able to install wmp 9 unless I have IE6. Also maybe some of the codecs or whatever might be needed to play some of the videos I want.

See More: IE6 wont install after recovery

Report •

December 19, 2009 at 18:34:25
You say you're getting a message that some components cannot install. What happens if you reboot and try to run IE? Do you receive any errors then? Have you tried a Repair Install of IE?


Report •

December 20, 2009 at 11:47:31
I tried the 'create old uninstall' folder method which worked the firsrt time I used the recovery disc but not this time. How do you do a repair install? Is that in the add/remove programs because some programs have that option when you try to remove them. I'm afraid to click 'remove' on the windows media player because if it immediatly goes to remove I will have no wmp. I could download one but I'm not sure that would work right because even if I try to install version 7 its version 9 that gets installed and I don't know if that will work unless I get the IE6 installed.

Report •

December 20, 2009 at 14:25:52
What was wrong that prompted you to run the recovery in the 1st place?

Do you have backup discs with WMP9, IE6, drivers, etc on them? or do you have to redownload everything from scratch? If you don't have backups, you just learned a valuable lesson...not only should you backup your important data, but you should also backup your drivers & programs. And you should immediately turn off System Restore & leave it off. It doesn't work right & never did, all it does is screw things up & slow the system down.

Contrary to popular opinion, WinME was a decent OS, but it has to be setup properly. There are a LOT of tweaks that should be done to make it perform well & one of them is to turn off the stupid System Restore! Follow Black Viper's tweaks:

"I'm not sure that would work right because even if I try to install version 7 its version 9 that gets installed and I don't know if that will work unless I get the IE6 installed"

Don't be so paranoid about installing's just a computer, it can always be fixed. Besides, WinME shipped with WMP7, you don't have to reinstall it.

Download & save this file (it's a direct download link):

Windows Media Player 9 Series (for Windows 98 SE, Windows Millennium Edition, and Windows 2000)

Unfortunately M$ didn't supply a full downloadable version of IE6 so you have no choice but to use their installer:

Internet Explorer 6 Service Pack 1

"Now my CD and Labtec webcam work however I can't get internet explorer installed"

Unplug all non-essential hardware. You shouldn't have your webcam hooked up, or printer, scanner or any other external with them later. Until you get windows installed & fully updated, the only externals you should have connected are the keyboard, mouse, monitor & whatever you use to access the internet.

Report •

Related Solutions

December 21, 2009 at 21:16:47
I finally got it . Here's how. I found this.
Hi, To resolve this problem (for Mellienium Edition) as I had the same problem...

Make sure you still have the ie6setup update folder downloaded to your computer and
ready to go.

Next, delete:


Using explorer it is found in:


(a reboot is not required just delete it) and then run ie6setup.exe again.

This is the file causing your problem and ie6setup writes it anew and completes the
installation. Cheers.

I couldn't locate the CatRoot folder in search until I case sensitved it this way. C:\WINDOWS\SYSTEM\CatRoot Then I saw the file {F750E6C3-38EE-11D1-85E5-00C04FC295EE} mentioned above and deleted it. I rebooted then used a downloaded install of ie6with service pack1. As it was installing twice I got a message about a target file being newer or something and I clicked continue on both times. Boy was I glad when it restarted to ie6!

Quick Reply

Report •

Ask Question