Articles

Cannot format D: drive

Dell/ Dimension 4100
January 20, 2007 at 19:25:00
Specs: ME 4.90.3000, Pentium III/256 k

Installed a 40 gig drive from another computer. I wanted to use it as a mirror, for backup. When I tried to format the disk I received "Windows cannot format this drive. Quit any disk utilities...etc..
How can I get this drive formatted? DOS?
Any help will be appreciated.
Thanks,
Bob

An Anglia is an English Ford


See More: Cannot format D: drive

Report •


#1
January 20, 2007 at 21:16:49

As you sure it's FAT32?


Report •

#2
January 20, 2007 at 21:49:26

If all else fails, then sure, DOS - but it should be 'doable' from within Windows.

Has it been partitioned, or (as mentioned by Demetri) is it partitioned as FAT32? You can check via the drive's properties in 'MyComputer'

The NT file system common to XP/2K is not compatible with WinME, and would need to be removed and replaced, if that is the case

I'm not one of those who think Bill Gates is the devil. I simply suspect that if Microsoft ever met up with the devil, it wouldn't need an interpreter


Report •

#3
January 21, 2007 at 04:59:48

"windows cannot formatt this drive. quit any disk utilities or programs that may be using this drive, and close any open windows with the drive contents showing"

Boot with a floppy boot disc then at the a:\ prompt type format d: then enter

You can get a boot disc from HERE


" If at first you don't succeed, Please Post Back "


Report •

Related Solutions

#4
January 21, 2007 at 06:03:04

Also, just be sure you do NOT have Windoze ME installed to the d: drive/partition. The error message you're getting does suggest that possibility...

Otherwise once sure you want to reformat d: - and have copied elsewhere anything you want to preserve... - use the 'ME bootdisk (format util) to do the job; being careful to address and reformat the correct drive/partition.


Report •

#5
January 21, 2007 at 11:19:24

Jam...It is Fat32
trvir...The disk was from another ME machine and still has the OS installed on it. I tried to format the drive in DOS, but it wouldn't let me.
I have created a boot disk and will try to format the D drive.

Thanks to all,
Bob

An Anglia is an English Ford


Report •

#6
January 21, 2007 at 11:51:49

Presumably you have installed this second drive a Slave to the original (now set as Master with Slave).

As long as the drive/partition which you wish to format is not the one which is running the OS at the time... you are "usually" able to format it from within windows (current format permitting...).

Presumably you have your ME booted up into c: (your original HD in your PC) and the - second drive (also with an installed OS on it) is a second/separate (slaved) drive (d: )?

If so then quite why you are having the error message???

Still - using a '98 (or ME) bootdisk ought to get around it all.

Again be sure you address the second hard-drive; the command (froma dos (a:>/ prompt) would be:

format d:

If it still refuses... then run Fdisk and inspect that partition (on the second drive); and if needs-be, remove/delete it, then reconfigure drive afresh and format.

If at all in doubts about addressing the correct drive... disconnect the original (c: ) drive in your PC; then set the second drive as stand-alone Master; then apply format/Fdisk rouines as appropriate... Afterwhich reconnect original drive (Master with Slave) and the second drive again as Slave.

Full/detailed Fdisk/format "how to" etc..

http://support.microsoft.com/kb/255867


Report •

#7
January 21, 2007 at 12:41:08

Success....
I shut down all processes except Explorer..
and I was able to format the drive. Now I have a new question, Who makes a software package, which will mirror the entire C disk to D? (including the OS)
Norton Ghost doesn't list ME as an OS.

An Anglia is an English Ford


Report •

#8
January 21, 2007 at 13:08:13

That as a problem/solution is a new one to me...

http://www.computing.net/windowsxp/...

http://my.computing.net/windowsxp/w...

may be of help/interest in your latter request?

There is a degree of mutual/cross-referencing in these two links...


Report •

#9
June 28, 2007 at 21:35:13

Me? A novice by all means, but also a tweaker at heart. Had same problem with formatting my slave.

I searched all the post for help and most of them were over my head.

Took matters into my own hands,

Went to: Start, Run, typed in "Format D:" enter

The MS Dos CMD prompt window appears and states:

"WARNING ALL DATA ON NON-REMOVABLE DISK DRIVE D: WILL BE LOST, DO YOU WANT TO CONTINUE FORMAT! Proceed with format (Y/N)"

"Y" enter

CMD prompt states; "Format cannot run because the volume is in use by another process. Format may run if this volume is dismounted first. ALL OPEN HANDLES TO THIS VOLUME THEN WOULD BE INVALID. Would you like to try to force a dismount of this volume? (Y/N)"

"Y"

"xxxxxxx" enter (Volume name as shown on drive directory in explore)

"Volume dismounted. All opened handles to this volume are now invalid. 0/100 percent completed."

Finally success, too easy!


Report •


Ask Question