win 98 internet explorer

April 29, 2013 at 05:28:02
Specs: Windows 98se, amd athlon 512 ram
I have ie 5.5 installed but am unable to access the internet. Is there an updated version that will run win 98se. i am at my wits end. Please help, thank you

See More: win 98 internet explorer

Report •

April 29, 2013 at 06:37:38
Internet Explorer 6 SP1 was the final version that runs on Windows 98. Get it here:

If you are in any doubt about it's compatibility with Windows 98, please scroll down to "System Requirements" and you'll see that Windows 98 is listed.

Please be aware that the problem you're having may not be related to Internet Explorer at all. You may have a hardware problem with your internet equipment or there may be a problem with your internet provider.

Report •

April 29, 2013 at 18:34:08
Huh? Did you overlook my response in your previous thread from a few days ago:

where all your questions were answered?

DAVEINCAPS - Made with REAL high fructose corn syrup.

Report •

May 1, 2013 at 12:01:01
Additionally, you only need IE for Windows updates. Seeing as there are no new Win98 updates, you don't need to use IE at all. There are other browsers that will provide you with a better experience and may be more secure than IE 6.1.

Report •

Related Solutions

May 2, 2013 at 10:59:56
does anyone know of a browser that will run definately run 98se other than IE6 SP1.....thank you

Report •

May 2, 2013 at 13:45:33
Firefox 2.0 will run on Win98. You can try it. Get it at the link below.

You could also try Opera. I never used it so I can't comment at all but the link below will get you the latest for 98.

Report •

May 4, 2013 at 16:49:17
"does anyone know of a browser that will run definately run 98se other than IE6 SP1....."

Might not hurt to look at this as well:

"Channeling the spirit of jboy..."

Report •

May 14, 2013 at 11:18:37
Thank you but i am still trying to download and install ie6.1. after trying all suggested downloads to date. Anyone heard of ace explorer? does this work. Am on the net intermittently with ie5 but not good. Thank you to all for advice on graphics and sound drivers, all worked bar ie!!

Report •

May 14, 2013 at 19:15:06
Get a full copy of IE6 SP1 Here:

Or better yet, use Firefox

Last Flash Player for 9x:

Last Java for 9x: (right click to save, ignore "unsupported OS" message)

Report •

May 24, 2013 at 15:37:59
Whatever you download, do Save it is a file rather than running it online. Double click the saved file to install.

Always pop back and let us know the outcome - thanks

Report •

Ask Question