Pc No display on old E machine

Emachine / 400id
February 2, 2010 at 12:17:21
Specs: Windows XP
I just plugged in my old E machine to see what info I still have on the hard drive. I plugged it in and it booted up as far as I can tell but no display and when I hit the caps lock or number lock on the keyboard none of the led lights turn on. What to do to get this working?

See More: Pc No display on old E machine

Report •

February 2, 2010 at 19:00:07
It's probably not booting up. You heard fans and drives spin up and some LED's flashed but that just means the hardware is getting 5 and 12 volts

Was the PC working OK the last time you used it? Did anyone mess with it or did anything happen to it?

What about the video? If you originally had an on-board port and added a card, try both ports.

But likely the problem is with the power supply, motherboard or both.

You're not really green until you're soylent green.

Report •

February 2, 2010 at 19:47:53
Yeah I just took out the hard drive and will plug it into another PC and transfer over the data.

Report •

February 5, 2010 at 12:34:07
I've had stuff like this happen to me before. What I've found is a poor connection on the vid cable or the vid card could have come loose because of rough handling of the computer being tossed around from spot to spot. Also some monitors aren't compatible with some computers.

Report •

Related Solutions

February 5, 2010 at 14:00:50
On this desktop the video card is soldered on the motherboard so there are no adjustments.

Report •

Ask Question