Articles

Help - my laptop is SO slow

toshiba tecra8000
March 2, 2006 at 22:33:15
Specs: win98, 192MB

I am almost ready to punch a hole through my laptop screen and throw this piece of sh&t into the garbage.

My laptop is a Tosh tecra800 P2, 192MB ram with 20gig drive. I know it is old and maybe even obsolete though I mainly only use it for high speed cable internet.

The frustration is that surfing the net is so slow. When I first open IE, it takes about 1 minute to get into my home page (Yahoo). From there, each click normally takes 30 seconds to load a new webpage. Ebay searches easily take 20+ seconds and going into sections like myebay take 30 seconds. Going into my yahoo email takes 30+ seconds until my emails are shown. I know this is extremely slow even for a laptop of this power.

I know it is slow because occasionally after boot-up, my laptop surprises me for maybe 30 minutes where webpages appear in seconds (under 5) though after 30 minutes of use, it goes back to slow and sluggish.

I use AVG Free Edition virus protection which runs 24/7 when the laptop is on, and also Popup-Stopper runs 24/7. Other than than, no other programs load automatically (other than my printer software so I can print).

I daily get a MS error when opening new webpages. I can't recall the message, bbut basically 25% of the time when I attempt to open IE, the webpage starts to open and the MS displays an error asking if I want to send the error to MS and basically tells me it is closing the webpage. I then try again and usually get the webpage on the 2nd or 3rrd attempt.

What can I do to this laptop to make it reasonable speed for internet use. Any advice would be appreciated.

Thanks


See More: Help - my laptop is SO slow

Report •


#1
March 2, 2006 at 23:23:07

That does not sound like high speed broadband access to me. I'm using low speed broadband ADSL @ 512Kbs. There are few sites that are not available within a few seconds. Perhaps your ISP is delivering a sub par service. But more likely, you are generously hosting hundreds or thousands of malware which are using your connection to phone home.

Download Spybot Search & Destroy and AdAware. You'll find links to these at the top of the forum page (useful links). Both these programs need to be updated and run frequently.


Report •

#2
March 3, 2006 at 14:27:06

The check for spyware/malware already given is well worth a shot.

Otherwise you could try IE Repair. Double click the "Micorosoft IE & Tools" entry in Control Panel/Add-Remove programs and it should give you the option.

DerekW


Report •

#3
March 4, 2006 at 23:42:22

Yes, spyware can attack the system within minutes of ur being on the net and slow it down. Also have you tried clearing ur cache, run a disk cleanup and take out the temporary internet files, temp files etc.esp if the drive is running out of space. Has the HDD been defragged lately? Do these to improve speed, regularly will keep the system smoother.


Report •

Related Solutions

#4
March 7, 2006 at 14:03:35

I say download & update spybot too. Also try using firefox browser. If it flys then you know you got a problem with IE.

http://www.mozilla.com/firefox/

ASUS A7V8X
Athlon XP 2700+ @ 2.17ghz
1GB DDR 2700
nVidia 128mb FX 5200
WD 80gb SE
NEC ND-3500AG DVD R/RW


Report •

#5
March 29, 2006 at 09:27:52

All of the above is good advice (repairing IE, removing spyware, etc.)

In addition to Firefox, you could also try Opera. Both are better than Internet Explorer.

Also: If you have a separate router between your computer and cable modem, there could be a mis-configuration causing slowness.


Report •


Ask Question