Articles

Connecting External Hard Disk to PC

Packard Bell
March 18, 2008 at 12:36:11
Specs: windows 98 FE, Pentium II

I am trying to connect an external hard disk to my PC running under Windows 98 FE. I have loaded the driver software successfully, plugged it all in butwhat happens now! I just want to back-up all my files to external disk. How do I do this? There's no icon for the new disk - can anyone help?

See More: Connecting External Hard Disk to PC

Report •


#1
March 18, 2008 at 13:23:09

"I have loaded the driver software successfully, plugged it all in but what happens now!" Was the driver designed for Win98FE? Not likely that you found an External drive that had working drivers for FE.

If by chance you do have Win98FE drivers installed have you looked in Device manger to see if any USB controllers are identified there as working properly?

If none show or they are not working properly you may need to install MBoard chipset drivers.

Is there an icon with a green arrow in the tray by the clock?

Unplug the drive and reboot, then connect the drive. The described icon should appear.

Win98FE has very spotty USB support. Any drivers for the MBOard or the external drive enclosure must have Win98FE support.

There is a generic Mass storage device driver the MAY work for you if needed.


Report •

#2
March 19, 2008 at 11:43:59

Thanks vry much for replying to my question.As far as Device Manager goes, it tells me I have a "USB Mass Storage Device" and that it is functioning correctly - I take that to be good news.(?)
yes there is a little icon with a slantly arrow just next to the clockwhich tells me its "Safe to remove USB disk". Thats very helpful!!!!
My question is now (if I can assule its working OK) is how do I do a back-up to this drive. I read somewhere I have to go into DOS to do the file transfer. Any help on this issue of doing file back-up would be much appreciated. Thanks.

Report •

#3
March 19, 2008 at 13:16:05

OK, you don't have a drive letter in My Computer for the external? If not then it may not be formatted.

Try using the Safe to remove USB and then try to expand the Mass Storage device. You should then see the harddrive itself. The mass storage device listing is reffering to the enclosure, no the drive itself.


Report •

Related Solutions

#4
March 20, 2008 at 04:54:39

Thanks again for trying to help with my problem.
As you wrote, I don't have a drive letter in My Computer for the External Hard Disk Drive.
I tried the "Arrow" icon (Safe to Remove USB disk)and it seems to shut down the disk drive as it no longer appears under the expanded USB Controllor list.
When switched on, the expanded list for the USB controller tells me "USB Mass Storage Drive" (Hard disk Controller) and functions correctly, THEN the next expanded level down it tells me "MAXTOR S 6RA4" and that this is a disk reader and also that it functions correctly. So I've got that far.Any help on what I do next would again, be much appreciated. (PS.My Windows version is in French so the translations may be slightly different to what you see in the English version of Windows).

Report •

#5
March 20, 2008 at 05:20:35

I think your problem is that the drive is not currently formatted. Unformatted drives will not show up in My Computer. When using Win98 I am not sure if there is an easy way to format the drive. I will investigate this and get back to you. In the meantime see if there are any options to format when you do see the drive as you described above.

Report •

#6
March 20, 2008 at 11:42:10

Try this, open the safely remove icon. Expand until the drive is shown. Right click on the drive. Choose properties. What does that screen say? If the drive is disabled then try enabling.

What is the brand of the harddrive itself?


Report •

#7
March 21, 2008 at 01:29:51

I tried looking at the properties of the drive (the MAXTOR S etc) and all I could find under Parameters/Options was it had ticks in the boxes for Deconnection, Transfer of Synchronised data and "Unit Int 13" if that means anything. But under my Windows 98 I can see an option to "Enable".
The hard drive is a "Spire Gigapod VIII" 3.5 external drive - their website is at spirecoolers dot com, but their support email page doesn't work!!! Thanks again for your help.

Report •

#8
March 21, 2008 at 05:47:13

So did you try to enable? That site is working for me. So you assembled you own external drive by combining the Spire enclosure with a Mator drive. The drive is very likely not formatted, as I suspected above. I THINK using Discwizard software will enable you to partition and format the drive. Download the utility at the link below.

http://www.seagate.com/ww/v/index.j...


Report •

#9
March 27, 2008 at 11:20:13

I haven't tried the Discwizard software yet, but I'm wondering how it can format the drive if I can't actually "see" it in My Computer - how do I tell this software where my disc is?
I'm wondering if the simplest solution is to get an Upgrade to Windows 98 SE as this version is supported (according to the outside of the box!) for my external drive.
Thanks again

Report •

#10
March 27, 2008 at 11:56:00

If the storage device is being recognised by Win98FE then upgrading the SE isn't going to improve the situation.

One question I haven't asked before is this. What is the capacity of the USB drive? If less than 127GB the simple solution may be to temporarily connect the drive to the internal controllers in order to partition and format. Once that is accomplished you should be able to place it back into the enclosure.

How is the harddrive jumpered in the enclosure? Normally these enclosures require a master setting or even total removal of all jumpers.

As I stated, but possibly not clearly enough, there are two components to the external drive. The enclosure, which appears to be working, and the hardrive inside, which is not being seen in My Computer.

Normally Win98 will not allow you to connect a harddrive to the system without formatting it. That statement is based on IDE controller connections, which was the main harddrive connection method when Win98 was written. Now you have USB. Normally when you buy an complete external drive package it comes pre-formatted using FAT32. This is done to maximize compatibility.

You are caught in a catch 22 situation of your own making. You have elected to use USB because Win98 by default can't access a drive partition larger than 137GB. Additionally your computer BIOS can't properly configure a harddrive larger than 137GB. In order to use a drive with a capacity larger than 137GB on your system you are compelled to use an external drive. External USB/1394 drives are not resricted to that 137GB barrier on your system.

I believe that once that harddrive is partitioned and formatted your computer will be able to access the drive. The problem now is to prepare the drive. Because you can't access the drive the nomal way I am suggesting the Discwizard software. This software installs to a bootable floppy or CDR and therefore isn't reliant on Win98 to configure the drive. The only issue is wheather or not the software will see the USB drive.

If that doesn't work you may need to temporarily connect to a newer computer to partition and format the drive.


Report •

#11
March 28, 2008 at 02:45:32

Thanks for all your information. The shop where I bought the drive, sold me the enclosure PLUS the hard drive and put it together for me - I had the choice of 80 or 160GB and as the price difference was minimal, the shop assistant suggested I go for the 160 - which I unknowingly did! So maybe I can go back to them and ask them to partition the disk for me. I think its the least than could do after all the wrong advice they have given me. I'll let you know how I get on. Thanks again, Greggo.

Report •

#12
March 28, 2008 at 06:23:42

That should work for you.

Report •

#13
March 28, 2008 at 09:06:56

I went back to the shop where I bought thethe external drive enclosure and disk and they hooked it up to one of their PCs: they told me the disk was formatted (called HD on their system?)but I'm wondering if there are different types of formatting other than the FAT32 - or maybe its formatted but not partitioned. They keep telling me I should upgrade to Windows 98 SE but I'm not sure this will fix the problem.
Oh, I also called the manufacturer this morning in the UK - he said that the SP167 should run under Windows 97 (I think he meant Windows 98 - doesn't inspire a lot of confidence!) and also said what you have said, that is make sure the disk has been formatted.
I've tried connecting everything up again but still notheing show in My Computer although everything things seems to be there under the Device Manager for the USB (Mass Storage Device, Maxtor S, etc).
Maybe I can try the device on someone's newer version PC and see for myself if its formatted, though I'm not too sure how to format the disk. Thanks Again.

Report •

#14
March 28, 2008 at 10:08:10

If you know someone with a WinXP or Vista system connecting the drive to a USB port there should be plug and play. It is possible the drive is formatted NTFS. Win98 can't access that fiel format.

It is possible there is some other reason Win98FE can't access this drive but it seems to me if that were the case you shouldn't see the enclosure or any information on the drive itself.

Have you tried both booting with and without the USB cable connected? Also, you could try going to Control Panel> add hardware. First try automatic detection. Then if no luck try devices by type and choose the closest match. One other thing, did you install the drivers BEFORE connecting the cable?

Did you check how the jumper on the back of the drive is set? I would try removing it completely if it is on.

I just thought of another possible reason for the troubles. The external enclosure MUST be able to configure drives larger than 127GB. Older external enclosures were hampered by the same limitations as the older BIOSes. Look at the paperwork for the enclosure. You are looking to see what capacity harddrie it can support or if it is 48bit LBA compliant.


Report •

#15
March 28, 2008 at 10:08:44

I think I have had some success!!!!
I went back into Device Manager and expanded the Mass Storage Device down to the MAXTOR S disk. I then went into parameters - one thing I hadn't tried was clicking on "Removable" disk - I tried this and I was then given the option of assigning a letter to it - I selected the next available D:
When I did this it then showed up under My Computer. Whoopee!!
When I clicked on the D: icon it said the disk wasn't formatted so I went through the formatting process - it would only allow a max. of 152GB but I continued anyway. It appeared to format OK.
The D: now appears under My Computer and when I go into Explorer. SO it sounds hopeful - now I just have to work out how to transfer my files to it - this was my initial purpose - being able to backup my files.

Report •

#16
March 28, 2008 at 10:21:58

152GB is the full size. This discreprency is due to different methods of measuring drive capacity.

I am glad you finally have it working.

Remember to use that icon by the clock to safely remove the device. Failure to do that will eventually result in data corruption.


Report •

#17
March 28, 2008 at 12:12:32

Many thanks for all your help on this - I'm really grateful - I think it was your suggestion that gave me the idea about trying the "Removable disk" option. Anyway it works and I can transfer files. I will remember to use the arrows before removing the device. Thanks.

Report •

#18
March 28, 2008 at 13:12:14

Back in #3 I suggested expanding the listings. Anyway, Glad I could help.

Report •


Ask Question