Command prompt only

Tiny computers / Pentium iii
June 23, 2009 at 06:34:13
Specs: Windows 98SE
While trying to install a wireless usb adapter yesterday, I found that some vxd files were missing. The adapter had worked earlier, so I decided to reset the system using Powerquest Second Chance.

Halfway through the restore the computer rebooted with Microsoft copyright 1981 -1999 and the C prompt.

Now reading here it says that the autoexec.bat and config.sys are unnecessary. However, they were missing from C but I found them in the PQSC folder.

Having copied them to C I find that the PC will now load the Oak Tech cd rom drivers as before. But reading further on this website, I find that there should be a himem command in the config.sys.

There isn't one.

I am completely lost now, I have no system disk as Win 98SE was preloaded.

I have found a site called Would this load windows? All of the files on the hard drive seem ok, so I am reluctant to do a full restore if it can be avoided.

Any help will be gratefully appreciated.


See More: Command prompt only

Report •

June 23, 2009 at 09:41:26
... quick google:

... if your system is so trashed that it won't boot into Windows, you can boot to DOS from a floppy and restore the last good Checkpoint from there.

... If you cannot boot into Windows, you can use an emergency boot disk that the program creates to load a 16bit version of Second Chance and restore your drives from there.



"...pentathol makes you sing like a canary"
... got brain freeze

Report •

June 23, 2009 at 13:13:45
Thanks for the reply, Mavis.

I have a floppy that came with the system back in the day when it was young and fresh.

That allowed me to see the earlier checkpoints and said that I could restore to one of those. It goes throught the motions but on reboot comes back to the C Prompt.

It is so frustrating. All of the files are on the hard drive. Scandisk didn't report any major errors other than corrupted files in autoexec05.bat.

At the moment I have just tried the bootdisk for It appears that msdos.sys and io.sys are absent from my system. Attempts to SYS C: them are meeting with No System on Default drive. I'm about to google that.

Having never installed an OS or messed around with a PC at this level, it's beginning to fry my brain!

If I have any joy I'll let you know.

Thanks again, it's nice to know someone cares

Report •

June 23, 2009 at 13:36:36
... sys'ing your drive aint gona help as the msdos.sys + io.sys blah blah ar'nt the gui ones....

.. how about trying that floppy again ...but NOT to the earliest checkpoint(s) but the one closer to this date.....then

... when thats done ....reboot... tap "F8" key @ command prompt...[press ENTER]

... (type) scanreg /restore [ENTER]

... then select another date with arrow keys ....[ENTER]

... see what happens!


"...pentathol makes you sing like a canary"
... got brain freeze

Report •

Related Solutions

June 23, 2009 at 14:09:29
Sorry, it's still the same:

Microsoft Windows 98
Copyright Microsoft corp 1981 - 1999


I put the floppy in and got this message.

This disk provides you with several methods of recovering your system

1 second chance:

use this to set your computers software back to a previously good state press y to run second chance

I've got checkpoints 2009 to 2023 - the rest are before and after restore to 2009, 2013 and 2019

I've gone for 2012 as that was the last but one before the trouble started.

I then got the options of safe mode and the rest, I tried the command prompt and scandisk/restore

I only had two options but tried the one for the 22nd of June the restore was from the 21st.

Now I'm back where I started - but with a little less hair!

Thanks for your help though

Report •

June 23, 2009 at 14:12:24
Oh, in case you were wondering, the other options on the floppy are Restore. Which will overwrite everything - including all my niece's sims houses - argggggh.

And that's about it, the other things are tools to access when Windows is running.

Report •

June 23, 2009 at 14:45:15
I'm not sure what 'powerquest second chance' is but I bet it's some kind of drive overlay, since C: isn't recognized when booting directly from a regular bootdisk. You have to let the overlay load, then it should give you an option to boot from the floppy disk--at least most overlays will.

If you let it boot from the hard drive and end up with the C:\> prompt you can run SCANREG/RESTORE but that only backdates the registry and two other startup files. It won't restore msdos.sys or replace any missing files.

It's not a big deal to overwrite the dos versioin of msdos.sys (which you seem to have now) with the windows version. Check my #68 here:

I don't know if that's the only problem you have but it may be the place to start. I can email you a copy of my msdos.sys if you need it.

Report •

June 23, 2009 at 15:17:00
... I used have a boot-up 98 floppy with three files to rename (saved on floppy) to boot-up into windows 98 gui incase I had problems... and renaming back for dos (used bat file io.dos io.gui)
... it used to show a "chip" image icon when booting into windows instead of A: drive icon.
... that would be "virtual ram"

... io.sys ...msdos.sys....

... its been a while ...win98 ...the floppy always worked!

... moved house since...etc place is ...still "tits up" ...

... looking for it now!... give me a day or so.



"...pentathol makes you sing like a canary"
... got brain freeze

Report •

June 23, 2009 at 15:46:11
Hi Dave

I read one of your posts earlier where you helped someone from a school to reboot Windows.

As it happens I was just copying Msdos.sys from elsewhere on this site. I am also missing IO.sys though and need to find that.

I just tried typing Win from the Windows folder which gave me a VFAT Device Error. Microsoft KB siad to edit the Msdos.sys which is definitely missing - not hidden.

Thanks for the help. I'm going to try that now before bed.

Mavis - Thanks for the continuing help, sorry to put you to so much trouble. But much appreciated.

Can you spare any of that Pentathol?

Report •

June 23, 2009 at 15:51:51

Panic over

Mavis - call off the APBs

Dave, I could kiss you...

But don't worry I won't...

The system fired up after I wrote the Msdos file.

It has also restored to Checkpoint 2012 which I believe is credit to you, Mavis

So all in all, virtual drinks all round.

I really am over the moon

Thanks guys!!!

Report •

June 23, 2009 at 15:57:26
... thats ok but we're in 2009 !!

... lol



"...pentathol makes you sing like a canary"
... got brain freeze

Report •

June 23, 2009 at 16:08:52
You're right.

I've just got broadband this week and bought a shiny new Samsung laptop which has dragged me kicking and screaming into the 21st century...

Even so, I still love my old desktop. I only use it for colouring my illustrations, writing and surfing the web so it suits me just fine.

I guess it got a bit jealous of the new computer and threw a bit of a hissy fit!!!

Thanks again - you are a star!

Report •

June 23, 2009 at 17:21:33
I'm glad it worked out. The io.sys wouldn't have been missing. It, along with msdos.sys is a hidden file and doesn't show up with a regular DIR command.

Report •

Ask Question